Sangoma Phone - Godaddy Certificate - Alert Bad Certificate Error

Trying to get up to speed regarding TLS and SRTP with FreePBX. I have configured a Freepbx 13 (fully up to date distro and modules and Asterisk 11) server and I have successfully gotten a GoDaddy SSL Certificate installed.

My Admin and UCP interface comes up with the green bar and Lock symbol.

I have configured Grandstream GXP2160 phones and when I make my call I now see the Lock Symbol and the display of the phone, so I am making a secure connection with them.

However when I try to configure my Sangoma S500 phones I get the following error and the Sangoma Phones will not register …

== Problem setting up ssl connection: error:14094412:SSL routines:SSL3_READ_BYTES:sslv3 alert bad certificate
[2017-05-24 10:49:21] WARNING[25684]: tcptls.c:683 handle_tcptls_connection: FILE * open failed!

Any ideas FreePBX gurus??

Asterisk is unable to open your certificate. Probably due to permissions. This is why doing it through Certificate Manager is so important.

Hi Andrew @tm1000 ,

Thanks for the reply. The certificate was totally installed through the Certificate Manager within FreePBX, I actually had no problem installing the certificate.

The only problem I have with the certificate itself is when I go back to my System Admin > HTTPS Setup > Settings Tab I now get a whoops error …

As I had stated, I have successfully configured my GXP2160 through the Commercial EPM (used base file edit to accomplish this), don’t have any problems there, seems to work great and as I had originally stated I am definitely making secure calls based on the Lock on the display when I now make a call.

I am only getting this message on my console when I attempt to get a Sangoma S500 Ver to register.

The Sangoma phone did get its configuration from the server without issue over HTTPS and did update the firmware without issue over HTTPS.

Any ideas Andrew or anyone else??

Yeah. Go look at the other thread you posted in.