FreePBX | Register | Issues | Wiki | Portal | Support

Sangoma phone and EPM just not working together


#1

So I got four S505 here on site. I originally tried the “no touch” with the Redirect. Both Deployment and IP based. The phones just will not poll to the Portal. No DHCP Option 66 enabled on router

I do have global settings on EPM to point the PBX LAN address of 192.168.70.2

After that failure, I went on to manually connect the phones, and set the location of the PBX server on the phone for the configuration file

I also made a specific template for a phone I am testing, tried to “Save” Rebuild, and Update Phones"

I then set the extension to use that template from the PBX Extension setting. and rebooted the phone.

I am getting nothing.

Any ideas on what I am doing wrong?


(Lorne Gaetz) #2

A "proper"™ provisioning URL will take the form:

http://username:password@host:port

From the screen caps we can see you don’t have https configured, yet you are attempting to provision with https. We can see the http provisioning port is set to 84. We don’t know if you have Apache credentials enabled or not, if so it will say in EPM global settings.

If your DHCP server has an option 66 string, it will override whatever you put on the provisioning page in the phone, and might explain why your phone is not polling the redirect server. If you need to override an option 66 string, then set ‘To Override Server’ to ‘no’.


#3

From what you are telling, It seems what is not clear in the setup guide in the Wiki is what "Upgrade Mode’ all affects. To me it seems it would only be for firmware, not the configuration server, if I am reading between the lines correctly.

I wanted to use tftp, and the PBX server Ip address is in the " Config Server Path"

I see in the /tftpboot folder there is a file named "cfg.xml for this extension 107 I am testing out.

DHCP Option 66 is not enabled.

I went ahead and changed it to tftp and tried again

I am still getting noting after clicking “Autoprovision Now” button and rebooting.

This is not the only issue I am having with End Point Manager.

As you can see, extension 108 is assigned to use the default Sangoma template.

Now let’s take a look at what EPM is showing about that:

As you can see, for some reason is it showing “Not in use.”

So now what?

Thanks for the help so far.


(Tony Lewis) #4

You need to give it the MAC. It can’t create the config without the MAC address.


#5

It seems FPBX does not like it when you include the colons between the two digits. I had originally put the MAC addresses for all four into there, but information from the “End Point” section of extensions would disappear.

So this extension 108 I put the MAC address in there this time, and now I see the configuration file for that one has been created.

I made sure the “Upgrade Mode” was set tp TFTP, made sure tftp://192.168.70.2 is in the “Config Server Path,” then clicked the :Autoprovision" button, then went back into the template, and did the save, reboot, and updates phones, and also did a reboot of the telephone.

It’s the same result as the other phone I am testing: nothing.

I can quickly verify if it took or not by the login password. I can still log in with admin/admin, and not the password set in global settings. Plus a custom template I made for the other extension 107 has some BLF assigned. .

I would just bypass this PIA by just doing it all manually, but it seems the only way to add custom ring tones to Sangoma telephones by going through EPM.

What now?


(Tony Lewis) #6

I would contact support. Something doesn’t seem right here and I am sure they can sort it out quickly for you.


#7

Resolved.

Turns out this particular ISO of Distro has tftp disabled, and no port set in the configuration file by default.

Thanks for all the responses