Sangoma PBXact 100 - not booting - run fsck Manually


(Eko VoIP) #1

I am having an issue with a new PBXact 100 - not booting – /dev/sda2: UNEXPECTED INCONSISTENCY; RUN fsck MANUALLY. (i.e. , without -a or -p options) , trying commands like fsck /dev/sda2 while it requires but no result just hangs on nothing happens, even if you try restarting many times same result, does anybody manged to solve this issue ?


(Communication Technologies) #2

Have you opened a ticket with Sangoma. They should be able to provide support for their device.


#3

Create a centos bootable USB and booty from there to recover your pbxact installation


(Eko VoIP) #4

I will do it, if not possible solving it by by using someone’s else in the community experience


(Eko VoIP) #5

I just wanted to inform you that I managed to solve the issue, by creating the USB bootable disk (CentOS7 minimal iso) and booted from usb then
choose Troubleshooting - Rescue Linux, then choose Option 1 - so rescue environment mounted on /mnt/sysimage and then wrote commands:
#fsck.ext4 -y -v /dev/sda2 – result : /dev/sda2 is in use, Cannot continue, aborting
or was telling other time
#fsck.ext4 -y -v /dev/sda2 – result: /dev/sda2 is mounted
then I run this command: # umount -l /dev/sda2 and # fuser -k /dev/sda2
and again
#fsck.ext4 -y -v /dev/sda2 which resulted with success showing some messages like : /dev/sda2: XY files, 4226/4333 clusters … and OK — system booted without problems.
Now when checking with fdisk -l and vim /etc/fstab it’s showing normal situation and values.

Thank you for the help guys.


(system) closed #6

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.