Sangoma P330 first time dialing a number it beeps, 2nd time the call goes through

Got a customer with a P330, when he tries calling out the first time he dials a number it beeps. If he immediately redials the number will work. This happens everytime he makes a call.
This is on Freepbx
They also have Sangoma S705 and some older Digium D50s that work fine.
I installed the latest firmware for D series phones on the freepbx.
How do I further troubleshoot this?

In command line:
asterisk -rv
if it’s SIP: sip set debug on
if it’s PJSIP: sip set logger on, adjust verbose to what you want, I usually just set to 10

Then view logs (In GUI Asterisk>Asterisk Logfiles

Did you load the latest firmware for P-series phones in EPM?

It’s 4_13_5…check it on the phone…

Do you have the same extension settings in freePBX as for the s705?

This extension is pjsip. I ran sip set logger on and get no such command. How do I set the verbose setting?

1 Like

pjsip set logger on
for pjsip or
sip set debug on
for chan_sip.

Thanks @Stewart1 that works. How do I filter it do to just show traffic from that ip or extension?

The latest firmware is in Firmware management. I need to confirm that the phone has pulled the latest firmware tho.

Sorry about that I had typed it in a bit of a hurry and forgot the pjsip portion.

In freepbx you can go to Reports>Asterisk Logfiles, it’ll default to the full log and there are search boxes you can use to filter by whatever you want.

The phone is on 4.13.5 As far as I know extension settings are the same. They have some older Digium D50 phones and a Sangoma S705 phone and those all work as expected.

I use a p330 with current firmware, pjsip, freePBX 16 and EPM. No problem…

I think I have the relevant log lines here. Untitled - FreePBX Pastebin Can someone help me interpret them?

Until a pro answers your question…
What is the expiration time setting for the pjsip extension? Is it different for the P330?

could be some MTU sadness. when we drop something in the 4_14 series (still making its way through dev) we’ll have a change in there that deals better with undersized MTUs


I’m reporting in with the same issues.

I have 40 P315s and most all of them seem to be doing this based on reports from staff. Some may not sit idle long enough. I can replicate the issue in my office. I haven’t had time to collect detailed logs yet. My pjsip timeout is 90 seconds and my sip keep alive interval configured in endpoint manager for my profile is set to 0.

Latest firmware 1.66.

This probably is an MTU issue that will be addressed in the next firmware version release 4_14, which should be available in the next few weeks. The work around until then is to move to TCP (or even TLS) signaling. If the extensions are defined with the default transport setting set to ‘Auto’ then you can control the signaling transport used at the EPM template level for P phones:

I’m not seeing the place to change to TCP.

Only transports that have been enabled and configured in Settings-> Asterisk SIP Settings can be selected. Changes to transports may require an Asterisk restart.

Thanks for your help, changing the PJSIP transport to TCP fixed the problem! Hopefully a proper fix is available soon.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.