Sangoma P330 Apps not working

Just moved two phones from a remote deployment hosted on Vultr to a locally hosted Sangoma UC25 PBXACT unit.

I tried to use the same settings that worked on the hosted freepbx instance, but Apps like status contacts even are just empty. I can make calls, and dial extensions.

Using DPMA with internal address vs the FQDN was the only difference I can see between the two instances.

If the Phones are local to the PBX do ports for the provisioning still need to be forwarded to the PBX? Or any ideas on things to check ?

No port-forwarding needed in a local network. You have the template set to ‘HTTPS’ while having an IP address in the ‘Internal’ field. For HTTPS you must provide a FQDN e.g. ‘’. This FQDN needs to match with the hostname in the certificate.
Keep in mind that internally the domain name will have to resolve the local IP address.

1 Like

Thank you for the reply and answer!

Does that mean I would need to edit the hosts file with an entry for the FQDN (with ssl cert)

Thanks again

Hosts on your local network need to be able to resolve ‘’ on IP It could be an static entry on your router or DNS resolver.

1 Like

To be more specific your phones need to be able to resolve that FQDN to the internal address. So changing the hosts file on your PBX will not allow your phones to resolve it. You’d need to have a DNS server on your network that the phones resolve names from that has this entry inside of it so that all clients resolve the name to the internal IP.

1 Like

Thank you Spioli and Dobrosavljevic!

The phone apps are working!

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.