Sangoma p320 call list is empty since last few months

I am not sure when, since last few months the call listis empty, users cannot see missed calls etc.

I am not sure what has changed. In the endpoint manager it is set to call list to be 50

Please help

Just want to report that I’m seeing the same thing, but only in about the last week. We have had some phones able to show it, and some not. Unsure where to even look to begin troubleshooting this.

Two separate issues here.

  1. At some point in the last few months there was a bug in an update that disabled CDR logging. You have to go into Settings => Advanced Settings and then find the CDR section. Make sure that “Enable CDR Logging” is set to Yes.

  1. We’ve had reports of that intermittent issue with phones not showing call logs from several different clients. The thing that fixed it for us was making sure all the modules on the PBX are up to date. Connect to the CLI of the PBX server and run fwconsole ma upgradeall and that should make call logs appear on phones again.

My timeline was module updates ran and our department lost access to call logs only on the phones. I ran through module updates this past Tuesday and that fixed it. One other user still couldn’t and I thought it was related, but I found that the user wasn’t associated with the extension, so that one is good. @mayoorpatelams try running through all module updates again and see if that fixes it, confirm it did for me.

I am not sure how to update cdr module update, I went system update and updated. I also rebooted the system. I am hosted at cyberlink.

I cannot get the phones to show missed call or any phone logs

Admin > Updates. Click the Module Updates tab, then click Check Online. It will show any modules that need updates in red in the list. Click upgrade all, then process. This will mark all for upgrade then take you to a confirmation screen. You may need to run through this a few times, depending on prerequisites.


In your case you may need to go Settings → Advanced Settings and go down to the cdr section. Make sure Enable CDR Logging is set to Yes.

Thanks, I suppose i was trying to reinstall or upgrade only cdr …

It didn’t help resolve the issue.

Was it disabled?

If it’s still not working after enabling it then an update is next. You could follow @driley_pine instructions or you can ssh into the PBX and run fwconsole ma upgradeall and see if that makes a difference.

Cdr logging is enable and can see the calls on reports cdr reports.

I have a funny feeling phone is not getting information from the server, maybe something is changed in how the phone conects to the pbx to the download the call list.

RESTful Phone Apps >>>> port 82 and I think in firewall it is set to internal

You are correct that it downloads it from the server. If it’s not working after performing updates and it’s worked in the past then I am not sure what else would have changed in your environment to stop these from loading in your phones properly.

Oh, you would see attempts by the phones to load the call log in the apache logs from the CLI as it uses the web server to load these logs. You can look in the /var/log/httpd/access_log file.

I am hosted at cyberlynk and just connected using winscp and cannot look at the directory. I suppose need to contact them to get access to the directory. I connect to it using vnc and am not too good at traversing thru directory using command language.

winscp takes me to root>> admin directory and cannot access root directory

thanks you are very helpfull >>> fwconsole ma upradeall …nothing to upgrade

WinSCP typically uses the SSH protocol. You should be able to use something like putty using the same credentials to get access to the CLI of the OS.

I have downloaded the file. What should I look for? I can post lines after xxxx ip address here.


I did connect using putty and used the command:
fwconsole ma upgradeall and got something like nothing to upgrade (I might not remember the exact reply and it did say something similar)

What are all modules required to see the call list on p320 … maybe a module is disabled.

Pretty sure it’s just the CDR Reports module, which you said is showing logs under Reports => CDR Reports.

The Apache log files should show the phones trying to connect and pull the CDR log from the server. Look for entries with the IP of the phone and see if they tell you anything.

Another thing to check is potentially the firmware version of the phone, is it at the latest version?

Fixed… Problem in User Management

User Management
Pbx internal Directory
Phone apps >>>> allow access

fixed the issue

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.