Sangoma P series phones still being prompted to select extension

P series phones
Upon provisioning (DPMA) or pressing Reconfigure on the phone, they are still being prompted to enter Global PIN and select an extension to provision.
The phones have assigned extensions under extension mapping (the MAC address is correct and matches), they are not being setup for hotdesking, XML-API (RestAPI) Default Login is set to NO (didn’t make difference if it was yes).
I want the phones to provision and just fetch the config for the extension they were assigned in extension mapping, and not ask to enter a PIN and ask to select an extension as if it were hotdesking.
I believe there is some issue with EPM while configuring these phones because it treats them like regular hotdesk phones; on the phone upon pressing ‘Applications’ there is a button for “logout”. I have set everything as expected for it to provision like a NORMAL phone and not hotdesk where they have to choose an extension so please advise how to avoid this…

After contacting Sangoma support they said that you have to click the “settings” wheel at the end of the row for that phone extension in Extension Mapping. That changes DPMA mode to “Server”, instead of “Phone”. With mode set to Server, it won’t prompt for the Global PIN or selection of an extension. I hope this is added to the phones’ documentation as I could not find this anywhere.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.