Sangoma Mobile Client SMS outbound fails

Greetings,

FreePBX 15.0.23.25
Asterisk 16.28.0

I have the Voip Innovations module up and running, valid certs, etc.
I am able to send and receive SMS/MMS with the UCP, Sangoma Desktop Phone with no issues.

However, when I try to send SMS from the mobile client I am seeing errors in the logs of the Sangoma Mobile client:

Error in API request (/mobile/sms/send) null Error code500 {“error”:{“type”:“Exception”,“message”:“Unable to locate the FreePBX BMO Class 'Smsplus’A required module might be disabled or uninstalled. Recommended steps (run from the CLI): 1) fwconsole ma install smsplus 2) fwconsole ma enable smsplus”,“file”:“/var/www/html/admin/libraries/BMO/Self_Helper.class.php”,“line”:212}}

I am also seeing that same error repeated many times on the server also. Whenever I try to send a text from the mobile app.

When I run the recommended action: fwconsole intstall smsplus:
[[email protected] ~]# fwconsole ma install smsplus
Unable to install module smsplus:

  • Cannot find module
    Updating Hooks…Done
    Chowning directories…Done
    [[email protected] ~]# fwconsole ma enable smsplus
    The following error(s) occured:
  • Module smsplus cannot be enabled

Since the UCP works bi-directionally for SMS and Sangoma Desktop, it is confusing why the Sangoma Connect Mobile client is having this issue.

1 Like

Please update the vi trunking module to the current edge version, 15.0.27. If you need assistance with the upgrade, or if the issue persists after the upgrade, please open a support ticket.

Thanks,

I opened a ticket before posting here. Trying to cover all bases.

The edge track upgrade didn’t fix the issue.

1 Like

I seem to be having the same issue. If you could post what you find out, I would appreciate it

No problem

Please update sangomaconnect module also to the latest edge i.e. v15.0.55 or v16.0.42 for 16 systems.

fwconsole ma downloadinstall sangomaconnect --tag=15.0.55

thanks

My v16 freepbx is working now. I can send texts again. Thanks. Hope it works for Rogue.

1 Like

Thank you,

After updating Voip Innovations module and sangomaconnect module to --edge. I didn’t try the fwconsole ma downloadinstall sangomaconnect --tag=15.0.55.

But it is fixed!

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.