Sangoma Connect Does Not Connect

FreePBX 16/Asterisk 16.8

https ://

Using Sangoma Connect for iOS exclusively. Followed the instructions above, not seeing any error messages on the server. I download the app on the iPhone, I get the invite email, I click the link and it auto configures (Great experience!)

The problem is that the Sangoma Connect phone on the iPhone never registers. It keeps cycling between “discovering” and “error”. There are no logs I can find on the phone and no further detail that I can see.

On the server it shows the Sangoma Connect account at “Authenticated”.

Any ideas on how to further troubleshoot this?

Followed ports, and firewall instructions, Sangoma Connect automatically added firewall rules, but I even tried to turn off the firewall, and there was no change.

Thanks in advance for any guidance.

I would double check your port-forward rules for SIP. You must allow access on your PJSIP port (check Asterisk SIP settings > pjsip tab) and the RTP range usually 10000-20000/UDP.
On the client app you may enable logging on Settings > preferences > Troubleshooting logs. The on Setting you will see a Log option. Those logs will show you what’s the transport (UDP, TCP, TLS) and what’s the port that the client app is connecting to.

1 Like

Looking at the sangoma connect logs, I see three interesting snippets

2022-08-21T03:29:53.184Z (1661052593184882)
Could not obtain any usable IP address for the following destination(s):
Correlation Id: SiphoneUserAgent[11D01F000]SipUserAgent[11D096000]SipTransaction[11D096578]SipTransport[11C2854A0]


2022-08-21T03:29:53.185Z (1661052593185101)
Correlation Id: SiphoneUserAgent[11D01F000]SipUserAgent[11D096000]
         State: Registering
         Error: ALI-SOCKET(6): Host Name Not Found
                In ali_net_sip_layer_transport.cpp:1513


DNS SRV record for '_sip._udp.https://MYDOMAINNAME:5060' is unusable or not available.

Any ideas here?

Would you post the settings from Connect > Settings tab?

Remove the ‘https://’ from there. It requires the fqdn only without transport.

1 Like

Still not working. Still getting those same errors in the sangoma connect log.

Also seeing this error

DNS SRV record for '_sip._udp.' is unusable or not available.
Using default address ''.

If you made a change on the settings page. It must be saved and the email invitation re-sent.

1 Like

That was it. Thank you so much for your help!

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.