Sangoma Connect Desktop Client Issue

Hello all. This is my first post.

I am trying to setup the new Sangoma Connect Softphone for Desktop and I am running in to an issue. I have gotten it to the point where it will sign in, but after successful login, I see no AOR and whenever I try to make a call it fails. (Address book seems to be working ok) I see the following at registration;

6226 [2022-03-01 10:15:48] VERBOSE[3953] res_http_websocket.c: WebSocket connection from ‘127.0.0.1:42010’ for protocol ‘sip’ accepted using version ‘13’
6227 [2022-03-01 10:15:48] WARNING[1578] res_pjsip_registrar.c: AOR ‘’ not found for endpoint ‘MyTrunk’ (127.0.0.1:42010)

Then the following when trying to make a call;

6228 [2022-03-01 10:15:55] ERROR[1578] res_pjsip_session.c: MyTrunk: Couldn’t negotiate stream 0:audio-0:audio:sendrecv (nothing)

I have tried to follow the guide, but I am not sure what I may be missing. I have the desk phones, and the Sangoma Connect Mobile phone both working over TLS. This system is hosted and not using NAT. I have the two seat demo license for Sangoma Connect. I’m not exactly sure why the error is referencing the trunk since the call I am testing with is internal to internal.

Does anyone have any thoughts or guidance?

Anyone out there? I am still having this problem, and now also having it on a second FreePBX. I even tried to configure Zulu as an alternative and I get the same Error in the logs.

[2022-03-16 11:53:56] ERROR[30481] res_pjsip_session.c: MyTrunk: Couldn’t negotiate stream 0:audio-0:audio:sendrecv (nothing)

This feels like it could be related to Codecs, but I don’t see anywhere that this is specified for the phones. I should also note that Sangoma Connect for Mobile works fine. Desk Phones Work fine. WebRTC Phone inside of the UCP works fine. The only place this is causing trouble is with Sangoma Phone for desktop and Zulu Desktop softphone.

Any advice would be greatly appreciated.

That particular error tends to be either because your media encryption settings are incompatible, or your allowed codecs are incompatible.

Provide a full trace: Providing Great Debug - Support Services - Documentation

The Sangoma Phone license purchase includes support (like all paid modules). Recommend you open a support ticket:
https://wiki.freepbx.org/display/FPAS/How+To+Open+A+Support+Ticket

1 Like

I did not realize that. I will create a support ticket if I can’t find a solution soon.

Thank You!

I was thinking the same, but hadn’t had success in testing yet.

Here’s something that is odd, when registering the Sangoma Phone Desktop Client and placing an internal call (extension to extension) I get that error which is referencing the trunk. I am confused as to why it’s even concerned with the trunk since the call is internal.

Our Trunk (Flowroute) supports G.711a, G.711u, and G.729. In my Asterisk SIP settings, I have enabled Only these codecs. Is there another place I should be looking for codecs in use for WebRTC or this softphone specifically?

I have also experimented with using different settings for SRTP and DTLS to no avail. I can try a few more tests with that as well.

For anyone else who stumbles across this, the problem was in the trunk config. I know it wasn’t there before, but perhaps it got added while I was installing some pre-requisites.

Under Connectivity > Trunks > pjsip settings > Advanced
there is a field for “Match (Permit)”. In that field, it seems that 127.0.0.1 got added somehow. After removing this, it fixed my issue.

Also, as a note, on one phone server it was NOT present, so I added it, saved the changes and applied and then removed it, saved changes and applied again. Hope this helps if anyone else has this problem.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.