Sangoma Card, incorrect settings in system.conf

I’m sure I am not setting a confirguration correctly, but I am unable to get the dchan=24 line in the /etc/dahdi/system.conf file to be hardhdlc=24. This needs to be done according to Sangoma support. If I manually change this and restart dahdi, everything works as we would expect it to, however, if I set do any updates, it goes back to default. What is the best way to make this change?

I am using the freepbx distro, 4.211.64-9 and configuring using the Dahdi Config module.

Cliff Olle

Well that would be news to me. I was always told to use PRI with dchan and BRI with hardhdlc. Who is support told you this?

This is from their support.
HI Cliff,

thanks for providing the support logger attached.
From the output of your asterisk CLI it looks like the D channel is bouncing up and down. As seen from “Primary D-Channel on span 1 up/down” messages"

I took a look at your support logger and it looks like you have both software and hardware hdlc enabled and are competing against each other.
To resolve this issue entirely simply edit the following file and change ‘dchan’ to ‘hardhdlc’:

Save and restart.
Leo D’Alessandro

Sangoma Technologies Inc.

I see the following which would indicate that the technician at Sangoma is correct. However, I still have no idea how to enforce this change. I didn’t use this tool, I am only referencing it due to the statement that Sangoma uses the hardhdlc.

  1. Run dahdi_genconf

This command will re-write /etc/dahdi/system.conf and will include both the Sangoma card and the Digium card, since they are all considered just dahdi spans now. It is important to note that dahd_genconf uses the syntax “dchan=24” to define a D-channel, but the correct syntax for Sangoma hardware is “hardhdlc=24”. Make sure that you make this change before continuing.

Any ideas? We go live today and I worry that someone will make a config change and take it offline while I am researching.

I have reached out to Sangoma on this.

Did you follow this guide.

Where it shows the 2 settings you must enable for sangoma?

I have Dahdi mode set to yes and have tried Digium mode to be True or False and get the same results either way. We only have the one A101 card in the system.

In both scenarios it uses dchan in the system.conf file and won’t work unless I set to hardhdlc and reload.

I do appreciate your assistance. Any other options you can think of?

Also, that is the document I followed to set up the card initially.

No it does need to be dchan that is the correct setting. You need to set both those to be true in Sangoma section then reboot your box. I promise you dchan is correct.

When I set both to true and reboot I get the flapping that I referred to in the previous post (and the reason for sangoma support). They state that “both software and hardware hdlc” with both settings to true. Disabling the dchan and setting to hardhdlc resolves the issue, although I am concerned that something else would be causing an issue here that I am overlooking.

OK well then something is wrong with your setup as that is suppose to be fine when using dahdi mode and confirmed it with Sangoma today.

I have requested Sangoma look at the logs again and see if there is anything else that might be set wrong that would make the card believe that hardware and software hdlc is on when it should be one or the other. I have only used the module to set the settings so I am not sure where I would have gone wrong here. All other settings are confirmed correct with ATT for communication.

As a side note, if I want to set the hardhdlc=24 instead of dchan would I need to simply remove the Dahdi module and use the wanpipe scripts? According to the sangoma documentation on their wiki the dahdi_genconf would set hardhdlc=24 as well in system.conf.

Just Googled freepbx hardhdlc=24 and found this. I have the same issue and created a new topic in Distro Discussions before I found this. Makes me feel better that I’m not the only one with this issue.

Same issue here guys, I’ve worked with the Sangoma techs and they’ve directed me to speak with FreePBX.

The issue is that after the setup-sangoma script is ran, the PRI line works correctly. After someone applies a change to the config via the webGUI, the sangoma config files are overwritten breaking the PRI line.

I’ve tried a number of things, chown mods, modifying the start script, creating my own startup scripts…nothing seems to work.

Try updating your dahdiconfig module, as we made some changes which should resolve your issue.

I have the reverse problem. I have a Digium TE121 PRI card. Until I got the recent dahdiconfig module, system.conf would have dchan=24, which works on my system. After the update, dchan=24 is overwritten with hardhdlc=24, which breaks dahdi.

Any ideas?