Sangoma A108 Card Will Not Show Up - New Installation!

Hello I am building a new FreePBX system with Asterisk 18 and have a Sangoma A108 card that will not show up in the FreePBX , I have tried installing FreePBX several times on several different boxes, and tried two different cards and it will not show in FreePBX. If I run lspci it shows in there, I also have a TDM410 card which shows in both lspci and FreePBX just fine. I have searched the forum and have seen others with similar issues, I have tried some of the suggestions and none of them seem to work. I would expect the Sangoma card to work in FreePBX since it is Sangoma. Apparently there is a bug that no one has found a fix for yet since some of the threads I was reading are 5 years old. Again the TDM410 card shows up fine in FreePBX, in the Console and also in the cfg files, but the Sangoma A108 does not, this is very frustrating that the Sangoma cards are much more trouble to get to work. I have already tried running the wanrouter status command and it shows as not running, even after starting wanrouter it still doesn’t show up. On my last attempt I ran lspci right after the installation completed and the card shows in there so the box is seeing it, but it is not being detected by FreePBX. I have tried Installing FreePBX with Asterisk 16 as well and the same results.

image

Yes it is an A108 even though it shows A104 in lspci, both A108 cards I have do this, and the second one I tried I pulled from my current working Asterisk box to verify it was not the card also shows as A104 in both my current and new Asterisk box, my current Asterisk box is not Sangomas FreePBX, but the card works in there fine.

Tried again this evening and the same results, the FreePBX just will not see the Sangoma card, wanrouter still shows that it is not running, even starting manually doesn’t help (likely because it is to late) there is obviously something not happening during the installation process of FreePBX that the wanpipe or wanrouter is not installing correctly or something.