S705 Boot loop when updating firmware

I’m trying to update the firmware on a S705. In the Endpoint Manager, I’m trying to give it version 1.48, which would be firmware for that phone. The phone just goes into a boot loop and never fully boots up. It gets to “Updating firmware” then restarts and starts the process over and over again. No other phones seem to have that issue. This is the only 705 I have and it has an expansion module attached to it. All my other phones are s500’s or s400’s. Any thoughts on a solution? I’d like to update the firmware on the s705 due to the fact that I have to restart the phone about once a day because it freezes up.

There have been reports of this if you are using tftp for provisioning. In those cases, changing to http (which is preferable anyway) fixes.

I assume you are using SNG7 based ISO. The upstream TFTP pacakge made some changes that causes large files like the s705 firmware to have issues when using TFTP. You can try a yum update to make sure you have the latest packages as we attempted to revert some of the changes theyade upstream to make TFTP play nice again with large files that take time to reply back as the phone verifies the data and applies it. Otherwise move to something like HTTP for provisioning which is faster and more secure anyways.

1 Like

That worked, thank you!

Which one worked? Upgrading RPMs or moving to HTTP

Moving to HTTP

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.