S505, truncating the SIP host field


#1

(edit to add snip from phone GUI)
Have been wrestling with remote S505 phones all day trying to get them to register. Just found by looking at the phone GUI that the SIP server name is myhost.mydomain.com:

…the port is missing off the end. For all the S505 phones, but not the legacy SPA504 and 514 phones. When I add 5060 after the colon in the phone GUI, they register.

When I look at the XML file in /tftpboot for the phone, the SIP host is complete, but it’s not in the phone GUI. The line from the XML file (name changed to protect the innocent):
<P47>phones.aaaabbbbbxxxxxcc.com:5060</P47> (so 32 total characters)

Phones are set to be using firmware 1.61 in EPM firmware management. The handset I have here shows Firmware IMG 3.0.4.75 on the LCD in Info.S505%20missing%20SIP%20host%20port


#2

Assuming that this is a field width issue:

Try removing the colon from the P47 value; the phone should default to port 5060.

Or, create a CNAME record for p.aaaabbbbbxxxxxcc.com that points to phones.aaaabbbbbxxxxxcc.com. (If using TLS, you’ll need to add the name to the cert.)


#3

I guess it would depend on whether that field is populated from Option 66 or from the P47 line in the XML config file for the device that’s generated by EPM. If the latter I’d have to manually edit the config file and then not let EPM update it. Better than having to remote into handsets to fix in the GUI, I suppose.


(system) closed #4

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.