S505 initializing loop - solved


(Brad B) #1

I just purchased a Sangoma s505. It boots up fine. Seems to retrieve its configs fine (I can toggle between a background image and no background image and it changes). However, every ~45 seconds the Initializing… screen pops up and the phone goes through the boot process again. I’ve changed option 66 from tftp to http and it doesn’t fix it. I’ve scoured the forums but any related posts that have fixes don’t work for me. I’m using freepbx 15.0.16.75 w/Asterisk 16.11.1. I don’t have any commercial modules activated. Also none of the vertical or horizontal buttons, arrows or hard coded buttons work. Any ideas?

UPDATE
I’ve done some more troubleshooting and it seems the boot loop only happens when the phone can talk to freepbx. When I put it in a vlan that cannot talk to freepbx then it’s fine. When I put it in the same vlan (voip vlan) as freepbx or a vlan that can talk to the voip vlan it boot loops.

UPDATE
I ended up deleting the template and mapping in EPM. I created a new template and then mapped it. I factory reset the phone and zero-touch provisioning worked. Still don’t know what the issue was.