S500 - Random Beep


(Ymd Ltd) #1

Hi All

I have about 30 S500 phones they have all just been updated to the latest firmware but several of them are randomly going Beep Beep through the loud speaker.

Have looked at the EPM and cannot see any setting that could cause them to beep twice?

Have made sure all voicemails are read and deleted just in case it was a BLF alert

Thanks


(Jordack) #2

double check the voicemail waiting tone.

Currently can only be turned off by using the phones web interface or doing a base file edit. Sorry forgot the exact code.

I did create a feature request to add it to EPM

http://issues.freepbx.org/browse/FREEPBX-14052


(Tony Lewis - https://bit.ly/2SbDAyc) #3

It is disabled already in the latest EPM. Update EPM and go regenerate your configs and push them to the phone.


(Marc Abbaticchio) #4

This is actually enabled by default in the latest EPM 13.0.103.1 on Sangoma S500. My boss was calling me saying his phone was randomly beeping and I thought he was crazy until I got a voicemail and had the same thing happen to me. When I added baseline entry P20118=1 it turns it off on the phone. This is only after applying latest updates. It was never an issue before.


(Joe Pruett) #5

I can confirm that the P20118 setting seems to be having the opposite effect that one would assume, and the epm authors also assumed. i upgraded a phone to the latest 3.0.4.55 firmware and still have the same issue. through epm, i use the enable voice mail tone and that actually disables it.

maybe a bug should be generated for this?


(Itzik) #6

As far as I understand, the issue is, that the phone does not follow the settings set in the EPM temple, for now you need to manually edit the basefile…

Per this report, there’s already an internal report for this issue. https://issues.freepbx.org/browse/FREEPBX-14052


(Joe Pruett) #7

it sure seems to be that a p20118 value of 0 means make a tone and 1 means disable the tone. after i switched the setting in epm to be enabled (1 for p20118), the phone stopped making noise.


(Itzik) #8

Yes. But look in the template, under options I think? There’s a setting to disable this VM tone. But it doesn’t work… Unless you do as you described.


(Ed) #9

After installing v15 I now have an s700 that won’t shut up (Lol). I have tried modifying template file, but with no success (FW has been updated and have tried older versions as well)…

Any thoughts??

Thanks.


(Itzik) #10

Does it have any Voicemails?


(Ed) #11

Yes there are voicemails and if I edit the phone they do shut off.

image

The issue is that any time the phone is Factory Reset, so is that setting. I have changed the template PCode 20118 and have also confirmed the option is part of the XML config file being served up to the phone during the boot. This appears to be an issue again as I thought this was resolved back in 2017 or 2018.


#12

Did you read the voicemails, thereby marking them read?


(Ed) #13

This issue here isn’t that the reminder tones “feature” works, I am trying to disable the feature. I don’t want to be reminded there are voicemails waiting. Since the LED indicator works as expected, that’s all I need. I work from home and have two phones in the office and two other phones in the living space that I don’t want to hear every few minutes.

Not sure why the issue restarted on v15 since I was able to modify the template on previous versions without issue and have several customers with the same expectation.

Just not sure why the latest firmware for the 500/700 phones doesn’t support the pcode feature.

thanks for the input.


#14

So just to be clear, the beeps are not in fact “Random”


(Ed) #15

I was building on what Jordack and
tonyclewis
were commenting on at the top of this post.

tonyclewisTony Lewis - https://bit.ly/2SbDAyc

Feb '17

It is disabled already in the latest EPM. Update EPM and go regenerate your configs and push them to the phone.

and

mabbaticchioMarc Abbaticchio

1

Feb '17

This is actually enabled by default in the latest EPM 13.0.103.1 on Sangoma S500. My boss was calling me saying his phone was randomly beeping and I thought he was crazy until I got a voicemail and had the same thing happen to me. When I added baseline entry P20118=1 it turns it off on the phone. This is only after applying latest updates. It was never an issue before.


(Dave Burgess) #16

Sangoma phone, so asking Sangoma directly would be a workable solution. You should have some product support for this device and should be able to set this up for you. Now, once you get the answer, please post it here to minimize the next guy’s angst.


(Ed) #17

Since I upgraded to v15 I have been dealing with several issues, like VPN clients not being able to register, adjusting the order of the “Line Key 1…n” options corrupting the template, EXPansion module data being wiped out… I was hoping to hear that someone had a similar issue with vmail tones or confirmation this was an issue on v15.

I have installed FreePBX many times and this is by far the biggest set of problems I have had to deal with. I am only here because the FreePBX backup I took, before migrating to v15, failed to restore.

I will update the thread if I do post and get a response from support.