S206 No Longer Registering

Hi,

I have a Sangoma S206 phone which was working using the Auto Provisioning feature at a remote site just fine.

I haven’t made any changes to FreePBX other than module upgrades and the same with router configs, and not the phone will not register.

I think it has something to do with the phone not sending the external IP address in the SIP header although Sangoma support thinks the port is blocked.

I have two older Aastra phones which are hard configured and they are registering fine.

Here are sample SIP Headers (IP addresses mangled by me for this post):

What I’m seeing on the Aastra is a message header with the external IP address:

Via: SIP/2.0/UDP 9a.8b.3c.2d:5060;branch=z9hG4bK5ab8dee7;rport

Max-Forwards: 70

From: "Unknown" <sip:[email protected]>;tag=as69956338

To: <sip:[email protected]:1025;transport=udp>

Contact: <sip:[email protected]:5060>

Call-ID: [email protected]:5060

CSeq: 102 OPTIONS

User-Agent: FPBX-14.0.13.40(16.13.0)

Date: Wed, 18 Nov 2020 03:48:18 GMT

Allow: INVITE, ACK, CANCEL, OPTIONS, BYE, REFER, SUBSCRIBE, NOTIFY, INFO, PUBLISH, MESSAGE

Supported: replaces, timer

Content-Length: 0

When I look at the Sangoma, the message header is showing the Internal address:

Via: SIP/2.0/UDP 192.168.0.171:5060;branch=z9hG4bK2750037179

From: "502-Metairie Small Office" <sip:[email protected][9a.8b.3c.2d:5060]:5060>;tag=ffea3567b4696d7

To: "502-Metairie Small Office" <sip:[email protected][9a.8b.3c.2d:5060]:5060>

Call-ID: [email protected]

CSeq: 1 REGISTER

Contact: <sip:[email protected]:5060;transport=UDP>

Max-Forwards: 70

Supported: path

User-Agent: Sangoma S206 V3.0.4.78.

Expires: 900

Allow: INVITE, ACK, UPDATE, INFO, CANCEL, BYE, OPTIONS, REFER, SUBSCRIBE, NOTIFY, MESSAGE, PRACK

Content-Length: 0


Anyone have any ideas?

Thanks,
Westley

Problem solved.

Turned off the SIP ALG service on my Mikrotik router and all is working.

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.