S206 auto-provision issues including logging into extension to connect extension to phone/mac?


#1

Hi there - Adam here. After years of using Cisco, Polycom, Yealink phones with EPM via and DHCP option specifications the feature of Sangoma phone auto-provision via rs.sagoma.net pulled us in on a new deployment with the intention to use the feature listed as:

“true Zero-Touch provisioning. This process allows the phone to auto-discover FreePBX / PBXact and auto-provision itself, simply by un-boxing a new phone and connecting its Ethernet cable to the network.”

our deployment plan including shipping the phones direct to the client, telling them to plug it in and to use the option to login on the phone itself with the extension and vm password to get the mac assigned to the extension (something I’ve done manually historically)… nothing worked.

I read all the instructions, watched youtube videos and after hours of troubleshooting over the course of several days still couldn’t get it to work so we opened a support ticket and was advised that the rs.sangoma.net was experiancing some issue which is why the phones were not autoprovisioning :frowning: and sure enough putting in the provisioning URL on the phones directly it worked right away. Notably support first suggested trying to update the firmware (which was 3.0.4.62) as older versions may not support auto-provisioning?

We were then advised that the s206 doesn’t actually fully support using the option to login on the phone itself with the extension and vm password and the s206 model needs to be assigned via the EPM yet that isn’t mentioned. I said surely that can’t be the case as the phone LCD does show the internal-external when we set the provision URL manually, but the end user couldn’t find any way to select the option on screen… so I went and manually assigned the MACs to the extension and got a couple setup…

So questions:

  1. I still show 0 poll count on the change redirection settings page - support was unlcear on what registers as a poll - I would assume all phones would regularly poll the rs.sangoma.net URL periodically and the counters should regularly increment? Not sure if this means there are still technical issues for rs.sangoma.net?

  2. do the s206 support extension support login (often reffered to as hot-desk) with the extension and vm password - and if so what button should be hit to select the internal/external option on the display? (I asked the user to try the directional pad and hitting 1, 2 keys which didn’t seem to work). Support just said its not supported on the s206 yet it shows the option and all of the website information suggests the phone supports this feature

  3. which firmware version is needed to support auto provision? These were phones purchased through Sangoma’s recomended reseller so it seems really strange they would ship with a firmware that wouldn’t support it? Both of the phones unboxed thus far shipped with 3.0.4.62

Thanks,
Adam


(Lorne Gaetz) #2

Hi Adam:

Not everything you relayed is correct and there have been no issues/interruptions to the zero touch service.

When you boot up a phone in the factory default condition, it will attempt to resolve rs.sangoma.net and attempt to download a provisioning file. If the phone successfully contacts the zero-touch server and downloads a file, it will increment the poll count twice. If you are not seeing the poll count change, either the phone can’t resolve the fqdn, or there is no route to that host.

That is a good question. I would have thought so, but this page does not list that device for Phone
Apps support. https://wiki.freepbx.org/display/FPG/Phone+Apps-Supported+Devices
My gut feeling tells me that it probably does, so please update your existing ticket with that question and request confirmation. Tell them to confer with me so we can confirm.

Any firmware supports auto provision. There was a firmware bug going back over 2 years now, where provisioning might fail only if you are using https AND you are using a very long fqdn (in the oder of 30-40 characters). What you’re seeing is not a firmware issue.


#3

Lorne - thank you for the quick response - I will update the ticket as requested. Seems like I got a lot of bad info from support, which I get happens and look forward to pushing this forward. Thanks again. I’ll post an update as things progress.


#4

Nearly 2 weeks later, no progress on my ticket. @Lorne - is this something you help with?


#5

Update: I got a response shortly after posting here - and while the language in the response is unclear, for which I’ve asked Santiago to clarify, the suggestion is that despite all the website and datasheet references stating the s206 supports both Zero Touch Provisioning and Hot-Desking - it in fact isn’t supported. :frowning:


(Richard Smith) #6

Well that’s wrong, I know the Zero Touch provisioning works on those because I have done it previously. In terms of Hot desking you have to change the Horizontal Key in the provisioning template to use the Login Phone App.

As Lorne said, if the Poll Status doesn’t change it means there is a network issue preventing it from reaching the redirect servers. Is there any DHCP66 or uPNP configured on the network? Once it does poll the redirect server it only tries again after a factory reset.