RTP Port Settings?

configuration
Tags: #<Tag:0x00007f702bd4eb10>

#1

My VOIP Trunk provider (voiptalk.org) specifies RTP 10000-20000. I have this set in my “Asterisk SIP Settings”, RTP Port Ranges.

I wish to install an external SIP phone (Grandstream BT200) on a public internet address behind a NAT. On the Grandstream “Advanced Settings” page, the default RTP port specified is 5004. (Must be even).

My questions are:

  1. Can the Grandstream RTP port stay at this default and I simply forward the SIP and RTP port 5004 through the NAT, or do I have to change the default RTP port to somewhere within the range defined in the Asterisk Server (10000-20000)?

  2. Do I need to enable Symmetric RTP in both the FreePBX Extension configuration AND at the SIP Client?

Many thanks

Andy Woolford


(Kevin Frost) #2

Set your GS SRT Port to something between 10000 and 20000 that is an even number. Symmetric RTP must be enabled at both ends for it to function.


#3

( not a biggie but your range is not an even number and Asterisk has IMHO been wrong all these years :slight_smile: , calls that start on port 20000 will not have B-leg audio ( about 0.05% failure with mostly two party bridged calls but why not eliminate those failures ?)

seq 10000 20000|wc -l

)


(Kevin Frost) #4

@dicko is spot on.


(Aaron) #5

Can someone explain why calls on 20K will have no audio. What is special about that single port?


#6

They will have audio, just one way audio, because rtp needs a two channels/ports, one carries the outbound audio and the other the inbound, the outgoing port will always be even numbered, the far end will always send media back on the next higher number and obviously 20000+1 is not within 10000-20000.

rtp set debug on

and watch


(Aaron) #7

So you should always end with odd ports. Makes sense.


#8

Go ahead and show us. I’m puzzled at what you are saying. The odd ports are for RTCP.


#9

@billsimon is actually the spot-on one, I apologize for confusing the issue.