Ringlogix Trunk

Asterisk 18.20.2

My trunk registers just fine, but I cannot receive inbound calls. Outbound calls work fine.

I tried switching from GUI to using the configs here: Asterisk Distribution Configuration Guide - Powered by Kayako Help Desk Software The trunk would not even register when doing it this way.

Ringlogix also had me enable “allow anonymous inbound calls”

I’m new to FreePBX so I feel like I’m probably just missing something simple.


;Dialed Number routing according to SIP To: header
exten => s,1,Goto(from-trunk,${CUT(CUT(SIP_HEADER(TO),@,1),:,2):1},1)






client_uri=sip:ACCCOUNT-ID:[email protected]:5060

That is a good start. The custom configs you set up are not appropriate, because you are putting chan_sip parameters into pjsip config files. The good news is that you don’t need them; please take them all out and go back to your original setup, except set Context for your trunk to

Next, confirm that registration and outbound calling are working again. On an incoming call attempt, does anything appear in the Asterisk log? If so, paste the relevant section of the log at pastebin.com and post the link here, and also report what the caller hears.

If nothing, go to the Ringlogix portal and check Registration Details for your trunk. See SIP Trunk Settings - Powered by Kayako Help Desk Software
Confirm that Contact shows your correct public IP address and port.
Also, check the Routing Method for your number; see Route Phone Numbers to a Service - Powered by Kayako Help Desk Software . If these are all correct, run sngrep and report what, if anything, appears there on an attempted incoming call, as well as what, if anything, gets logged at Ringlogix.

Deleted all the custom configs and switched my trunk context to `from-pstn-toheader’. Oubound calls still work but no change on inbound. Caller experience is complete silence and then call failed. Nothing appears in the Asterisk log.

I did verify trunk details with RingLogix and the routing method. We also registered an endpoint on the same network to the trunk to rule out any firewall issues, we placed/received calls successfully.

No output from sngrep during an inbound call.

It’s weird that on the same network I can register a phone or another PBX and calls flow just fine, but with the FreePBX it just fails. A pcap on the firewall does not even detect any traffic on an inbound call.

Is it possible that it’s my installation? It is a new install and I don’t have another trunk provider to test with.

I just used a FreePBX 15 server that has been in production with a working pjsip trunk for a few years now, no change to the behavior if I register a RingLogix trunk on it.

So I missed that I needed to re-run the “Detect Network Settings” for the external address after I moved the PBX to another location. I am receiving inbound calls now using the default trunk settings with the ‘from-pstn-toheader’ context.

Thank you!

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.