Ringing tones... UK, US and international

Installing a couple of digital systems at the moment - i.e. VoIP in the building and SIP trunks out and no analogue lines.

Problem is that if the user calls a UK number (domestic home number) they hear the connection ringing out as a UK tone.

If however they call a mobile number the ring tone they hear is American (so they tend to hang up thinking they have called someone abroad).

Calling Companies is hit and miss as to UK or American sounding ringing heard. Calling abroad also doesn’t give the ‘normal’ ring for that country.

Is there any programming that can be done to get round this issue?

That sounds like a problem with the ITSPs system.

It’s a little more complicate than that


particularly note

. . . However, since signaling from a call could come from various places (from the carrier, from Asterisk, or even from the set itself), you should note that simply setting the tonezone in your dialplan does not guarantee that those tones will be presented in all situations . . .

If there is no ring presented on the call then whatever you have set up in /etc/asterisk/indications.conf will be used, you should set your default country to UK in advanced settings for when there is no “far-end” indication present if the call has already a “ringing” indication then you are kinda stuck with that.

A specific example of UK/BT tones:-


Ringing sounds can come from Asterisk, from the phones themselves, or from the provider.

You need to make sure you program the phones (see the manual) and FreePBX (Advanced Settings module or General Settings module if you have that one, Country indications) for the country that you are located in. Providers are generally pretty good about having the proper indications based upon the # that is being dialed, but if setting the phones and Asterisk right doesn’t solve the problem, you need to try another provider.

1 Like

Thanks for all these… I’m still on the learning curve with these systems and it helpd point me down several paths one of which solved the issue…

I traced the problem back to the service provider of the SIP trunk ‘Gamma’, by adding an additional trunk line to ‘DC VOIP Solutions Ltd’ - which I use at home, and creating an additional outbound route through them by dialing 8 instead of the normal route out through Gamma with a 9 prefix, I found everything working as it should. UK ring tones and DTMF options when connected to other peoples IVR’s - everything working as designed.

Along the way I learnt a few things some useful some not so much…

So, if anyone want to ‘play’ with the dial tone on a Cisco Handset, in the Advanced, ‘Regional’ and Call Progress Tones try the following as the setting for Dial Tone…

[email protected],[email protected],[email protected],[email protected],[email protected];20(.380/0/1,.380/0/2,.380/0/3,.380/0/4,.380/0/5,0/5/0)