FreePBX | Register | Issues | Wiki | Portal | Support

Ringing instead of going directly to IVR


(jb05) #1

Hi,

Just a newbie in FreePBX, I setup my FreePBX connected with 1 POTS line, now during my test when calling to the POTS number from outside instead of directly going to IVR it rings(estimated of 20 secs.) first before going to IVR.
What do I need to configure to have it go directly to IVR instead of ring then IVR?

FreePBX Version: 14.0.11
Asterisk Version: 13.22.0

Thanks,


#2

Is the POTS line connected through a gateway? If so, there is a timer that controls when the call is presented to Asterisk. For example, on an SPA3102, it’s called PSTN Answer Delay. If you’re in a country where caller ID is sent after the first ring, set this to 4. If it’s sent after a polarity reversal, 1 should be ok.

If it’s connected through an FXO card in the server, check that the dahdi configuration is correct for your country.

If you still have trouble, provide details on how the line is connected to Asterisk, as well as the source (copper pair from central office, cable MTA, fiber ONT, etc.).


(jb05) #3

Hi Stewart1,

Thank You for your response.

Q: How the line is connected to Asterisk
A: There is an installed DIGIUM Card(not sure for the model/part number) in the Server and that DIGIUM Card have 2 FXO Ports and 2 FXS Ports, but only 1 FXO Port is active which means that is where the POTS line is connected.

Then base on your suggestion to check the DAHDI Config, the settings that I only configure is System Settings for Tone Region and Modprobe Settings for Opermode set them both to my country and the others are in default. But still the issue occurs.


#4

Make a test call and note the time when you first hear ringback and when you hear it answer. The clock on your mobile should be accurate to one second, good enough for this purpose.

Then, paste the Asterisk log for the call at pastebin.freepbx.org and post the link here.

We should be able to see where the delay is occurring.


#5

This is often caused by misconfigured cid settings on the trunk against the provisioner’s actuality, that is the first thing to resolve and often then compounded by fax detection (disable it)


(jb05) #6

Hi Stewart1,
Here is the logs that generated when I do the test call
https://pastebin.freepbx.org/view/10a091c9

Thanks,

Hi dicko,

Sorry but I’m a newbie in FreePBX so I’m not familiar with it, can you elaborate more or guide mo on how to do it?

Thanks,


#7

There are many posts regarding cid detection both here and in google land

Where does @JerryFernandez live? and from whom does he get his pots lines from?


#8

Sorry, but the log you posted has no timestamps. Did you get it from the file
/var/log/asterisk/full
or from the GUI Reports -> Asterisk Logfiles?

Either way, there is normally date/time info at the beginning of each line. Did you change a setting to remove them?

Please check and repeat the test with timestamped logs. Also, post the times you note when ringback starts and you first hear the IVR answer.

Also, in addition to the info asked by @dicko, confirm that your POTS line has caller ID service and you know it’s working.


(jb05) #9

Please see below of my settings for the CID:



Trunk (Settings)

Yes the POTS line has callerID, actually this POTS line is one of the 6 POTS line connected to our old FreePBX with the following details:
FreePBX Version: 2.11.0.37
Asterisk Version: Asterisk 11.8.1
Then now they want to replace it with a newer version so I borrowed one of the POTS lines from the old ones to use for the new one. But this issue occurs. I also setup all the settings that can configure the country in the system(Under Connectivity). This POTS line is just from our local telco provider here in the Philippines.

Logs with timestamp
The time of ringback is 17:00:12
The time of IVR answer is 17:00:20
https://pastebin.freepbx.org/view/9ef3085a

Thanks,


#10

I don’t know whether this is accurate, but


claims “PLDT uses DTMF, whereas, Globe and Bayantel having newer equipment uses FSK.”
Wow, I’ve never heard of different caller ID formats in the same country.

Look at the settings for cidsignalling and cidstart in your working system and set the new system the same. See

If you still get Failed to decode CallerID errors, find out what format your line is actually using (by listening with a butt set or by asking the telco), set cidsignalling and cidstart accordingly, retest.

If no luck, post what you found and a new log using what you believe to be the correct settings.


(jb05) #11

Hi @Stewart1,

Thank You for this response

This is the keyword that I used when troubleshooting and I got here:
https://wiki.freepbx.org/display/PC/Analog-+Enable+DTMF+Caller+ID

Now from 4 ring to 1 ring only when I try to call the POTS line
Also @dicko thank you for your response… :slight_smile:


(system) closed #12

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.