Ring Tone change not working properly


We are trying to set the ring tone from the phone menu. It does not seem to change the ring tone for incoming calls. But it does change on the menu setting and also when tested via the volume up button.

We have firmware S700



Same issue here.
Did you manage to solve this?


I believe the suggestions that were given at the end of this topic, solved that issue.

Hope that helps,

I’m assuming that you have these phones configured with EPM. If so, there is a switch called GUI Override under the Options tab. I haven’t tested it but if its set to Config File that will mean EPM will override any changes made on the phone. Set to GUI will allow changes on the phone to override anything coming from EPM. Might be worth a shot.

Problem solved.
In Advanced Settings I had to change Internal Alert Info from Ring1 to Custom, also “Use freepbx_menu.conf Configuration” from NO to YES and in Endpoint manager had to change Template / Options - GUI Override to GUI

If you change the ring tone from the menu of the phone LCD it should override whatever you have set as the default in EPM for ring tone for that phone. It does require firmware or newer and most recent EPM for that to work.

You do not need to enable GUI overide in EPM for ring tone from Menu LCD to work

I have a small setup of S500 phones to test a new setup. All phones are on firmware and the EPM is the built in version at v. and does not show any further updates are available. I have tried with and without the GUI Override option and every time I push a new config, the ringtone set through the phone screen reverts to the config file.

Some of the phones will be in close proximity, or use 2 accounts, so we need to have individual ringtone capability.

I am experiencing the same exact issue. This is a PBXact with latest firmware. Client sets the tone on her S700 and less than an hour later its reverted back to config.

I even set the option for GUI Override.

Any idea the cause?

Did anyone come up with a resolution for this yet? They still have the problem and just called me again today.

What firmware are you using?

I am upgrading it now.

Ok but I asked what version your own.

Firmware Version is on Recommended in the EPM template.

PBX Version: 10.13.66-20

S700 Phones
BOOT– 11:10:00)
IMG– 11:10:00)
ROM– 11:10:00)
DSP–9.0.3(Patch 1.0.0)

Ok and what happens if you use the latest firmware.

I updated to the latest firmware and after running a “Save, Rebuild and Update Phones” in the template it over rides the ring tone and sets it back. In the template I have GUI set for Override Config file. Is this not the correct place?

This is driving my client crazy that she cant change her ringtones on the phones for more than an hour.

Can you verify what firmware the phone shows it has.

Product Model S700

Firmware Version BOOT– 11:10:00)
IMG– 09:35:00)
ROM– 09:35:00)
DSP–9.0.3(Patch 1.0.0)

Hi @jessy5765, can you describe the steps your user is doing to change the ring tone.

Menu -> Settings -> Basic Settings -> Ring Tone

1 Like

Is there somewhere else in the phone system I need to have a setting changed so that it sticks? Im not throwing out the possibility is a misconfig on my end, but I dont see anything else. If they change the setting on the phone they said it will stick for about a few hours and then go back, which is most likely when the phone is checking in for config