Ring the 2nd line when the first is busy

I have Asterisk 1.2.18 & FreePBX 2.2.1 & have a Polycom 501 phone assigned to everyone which support multiple lines ie on the LCD you can see the extensions asssigned to a user as.

555 — Line 1 – Extensions which registers with SIP(Asterisk) – User A
8555 — Line 2 – Extensions which registers with SIP(Asterisk) – User A

So when now someone calls one Extension 555 to User A, & the scenario as below.

  1. A call comes in, He is busy on the first line Ext 555, then the call to ring Line 2 Ext 8555 as the first line was busy, if no response send to voicemail

  2. A call comes in, He doesnt picks(ignores) the line 1 Ext 555, then send to voicemail rather than ringging on his second line ie Ext 8555.

This is what I need, if I can do it with Follow me, then how. I would appreciate any help on this.

If your phone doesn’t have two lines set up on the screen then you need to go into the user interface of the phone (by entering its IP address in the web browser).

User is Polycom, password is 456

Go to lines and go to line 1. Where it says “number of line keys” put 2. Dont do anything to line 2 or 3.

If your phone is showing two lines on the screen, then you need to activate call forwarding on that phone by pressing *70 to activate and *71 to deactivate

Yes that true what you say, I need what you said, but the only difference was that my line 2 is having extension 8555 – OK I can remove that one.

I tried registering extension 555 on Line 1 & 555 on Line 2, but when I called it always rang the line 1 even if someone was on hold, it didnt ring the line 2 with the same extension.

Let me try again & see.

that’s a polycom setup issue. Unfortunately I don’t have time to dig in and tell you how to set it up right now (maybe someone else can chime in, or do a little research…)

The reason for 2 different #,s on line 1 & line 2 is Line 1 as primary Extension & Line 2 as secondary extension to make outgoing calls when he has someone on hold on line1.

Also I tried what ? said but that still ring the first line doesn’t roll to second when busy.

you are describing a very common scenario. I’ll re-iterate by describing my setup which is how most people with multi-line appearance phones set them up. I have a phone (well many, but we’ll describe the polycom). It is extension number 222. It has 222 on line keys 1, 2 and 3. If someone calls 222, line 1 rings. If I’m on the phone on line 1, or line 1 is already ringing and someone calls 222, line 2 rings, and so on. If I’m on the phone on any of the lines, I can just pick one of the other lines (no need to even hit the hold button) and make another call. Or do the same to answer another call that is coming in.

That sounds like what you are trying to do. That’s all there is to it. (Other than, make sure callwaiting is enable on the extension so freepbx sends multiple calls to the phone.

Any one having a clue on how to go about it.

why 2 different extensions? Just put 2 line appearances of 555 on the polycom. If he is on the phone, it will ring the second line appearance, if not it will ring the first. What you describe does not sound necessary.