Ring group looping instead of going to VM


Using FreePBX 2.4 on a Trixbox

I have a three stack ring group that was working just fine before.
Call came in, rang two extensions (BTW all are ringall!)
then called another ring group ringing three extensions (the two orginal and one more)
After that it rang all extensions in the office.
If no one picks up it was to transfer to the reception VM that is the main drop point for all calls.

Like I said used to work. We changed to an IVR setup. (Finally got that working!)

Now they decided they wanted the IVR for after hours but the ring groups for office hours.
So I switched it back in the Time Conditions (Which is called by the inbound routes)

It goes to the ring groups just fine only at the end of the third instead of transferring to the voice mail it it starts the ring group strategy all over again!
Tried the following:
Reloaded all ring groups and restarted Asterisk.
Set first ring group to call and go to VM. Works.
Tried other ring groups to call and go to VM. Worked fine.
Set first ring group to call last ring group and go to VM. Works great!

Reset to use all three, back to going in circles! !!!

Anyone with any ideas?

Thanks for the help,
Will try for a log and post it if I find anything…

Thanks Paris