Ring group failover when SIP endpoints unreachable

PBX and Trunk and “in the cloud”, SIP phones are in an office on a ring group. Normal operation is DID>RG>busy VM but when the office has no internet they asked it get forwarded to a cell. How do I build this logic into a RG?

Do you want the missed office call to go to each individual one by one or at the same time? Usually, if there’s a ‘no answer’ condition on a call, you can preset a misc. destination as where you want the request to go and set THAT missed call to another cell phone.So it would be like:
DID>RG>Office Busy>Misc. Destination cell phone 1 busy>Misc. Destination cell phone 2 answer

The obverse of this is ringing all PSTN cell phones at once which is way more complex. The cellular radios between different cell companies have different lag/latency issues for different areas. This would make timing (and subsequent call routing operations) very unpredictable. Relying on a secondary network to route mission critical calls should be a last resort. Whenever possible, try to keep all calls as in-house as possible.

For this, I would recommend your office extensions be coupled with a secondary extension, for routing to their softphone app which is running on SIP, logged in and joined to a ring group awaiting a call. For this to be effective, all softphone employees would need to stay off company wifi (if this is the ISP that keeps cutting out), mainly to maintain connection to cellular/lte thus making the signal less latent. That would look more like:
DID>RG1>Office busy>RG2 (mobile extensions).

With the second option, you preserve your announcements, music on hold and everything you’re paying for :smiley:

Great answer but I think you may have over complicated it. I am looking for:
Normal flow:
DID>RG>busy VM
Unreachable office:
DID>RG (unreachable)>misc dest cell

Idea. Add a spare phone to the RG. Like a network closet phone. Dont block CF on RG. Now set call forward unreachable to the cell. Now anytime the network closet phone goes offline. RG fowards to cell. Otherwise normal RG rules.

1 Like

I tried this and it does not work as expected :frowning:

Try adding # next to extension. In the ring group like

Also make sure the set the call forward in ucp under not available.

If that doesn’t work let me know what its doing.

Maybe its not reachable instead I mean.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.