Ring-group delay in ringing ATA

I have a ring-group defined with two extensions. 201 is digital phone. 202 is linksys spa2102 ATA to POTS phone.

The ring-group is the destination for the inbound route.

When I dial in, the 201 digital phone start ringing fairly promptly, but the 202 extension does not start ringing for two more rings. I have tried different extensions configured on other spa2102 ATAs and I still get the same behavior.

This behavior is shown on FOP also (the icon for 202 does not start jiggling=ring until about two rings later).

Ring-groups module version =
Follow Me module version = Enabled

FreePBX 2.4.0
Trixbox v2.4.2

I have made several changes to the extensions listed in ring-groups. So perhaps the original extensions ring first, and ones I added later now ring later?

Any ideas?

I solved the problem. In the spa2102, I had set several of the “NAT support parameters” involving “VIA”, e.g. “Insert VIA rport”, “Send Resp to Src Port”, “Subtitute VIA addr” to Yes as this was required by one of my VOIP providers. But when I switched to using the spa2102 as an internal ATA connected to my Asterisk box instead of directly to the VOIP provider, this caused some very odd behavior. It caused the unit to delay in starting to ring as per my first post; it caused the phone on this ATA to ring even after another extension in the ring-group answered. (I also changed a few other settings, but I think this was the culprit)