Retrieved Module XML Was Empty

Hi all,
I’m trying to setup a FreePBX machine on an UBUNTU 16 machine.

I followed these instructions (wiki.freepbx.org/display/FOP/Installing+FreePBX+14+on+Debian+8.8) albeit with some changes mostly because of using php7.

At the moment, though, I am stuck at a point where FreePBX cannot connect to its servers and download the required modules.

I found this thread ([SOLVED]Getting Data from Online Server...Cant Reach Online Server) but the solutions suggested in there do not solve my problem.
I even tried switching between static and dynamic IPs as someone suggested with no luck.

The full error reads

[email protected]:~# fwconsole ma upgrade framework
PHP Warning: Declaration of FreePBX\Console\Application\FWHelpCommand::setCommand($command) should be compatible with Symfony\Component\Console\Command\HelpCommand::setCommand(Symfony\Component\Console\Command\Command $command) in /var/www/html/admin/libraries/FWHelper.class.php on line 15
No repos specified, using: [standard] from last GUI settings

Downloading module 'framework’
PHP Deprecated: Methods with the same name as their class will not be constructors in a future version of PHP; xml2Array has a deprecated constructor in /var/www/html/admin/libraries/xml2Array.class.php on line 24
The following error(s) occured:

  • Retrieved Module XML Was Empty

My fwconsole ma list looks like this

| Module | Version | Status | License |
±-----------------±-----------±----------------------------------±--------+
| builtin | | Enabled | |
| callrecording | 13.0.11.4 | Enabled | AGPLv3+ |
| cdr | 14.0.5.9 | Enabled | GPLv3+ |
| cel | 14.0.2.2 | Enabled | GPLv3+ |
| conferences | 13.0.23.7 | Enabled | GPLv3+ |
| core | 14.0.1.9 | Enabled | GPLv3+ |
| customappsreg | 13.0.5.1 | Enabled | GPLv3+ |
| dashboard | 14.0.2.4 | Enabled | AGPLv3+ |
| featurecodeadmin | 13.0.6.4 | Enabled | GPLv3+ |
| framework | 14.0.1.16 | Enabled | GPLv2+ |
| infoservices | 13.0.1.1 | Enabled | GPLv2+ |
| logfiles | 13.0.10.3 | Enabled | GPLv3+ |
| music | 13.0.22.3 | Enabled | GPLv3+ |
| pm2 | 13.0.3.18 | Enabled | AGPLv3+ |
| recordings | 13.0.30.11 | Enabled | GPLv3+ |
| sipsettings | 13.0.24.8 | Enabled | AGPLv3+ |
| soundlang | 14.0.4.2 | Enabled | GPLv3+ |
| ucp | | Not Installed (Locally available) | AGPLv3+ |
| userman | 14.0.3.24 | Enabled | AGPLv3+ |
| voicemail | 14.0.1.9 | Enabled | GPLv3+ |

Any suggestions?

What is your php version

Hi!

You cannot use php7 with FreePBX, for FreePBX 14 you must use PHP 5.6…

The main problem with making FreePBX work with PHP 7 is a dependency on a third party tool, Zen Guard, which is used for the commercial modules so until a solution is found, it won’t be actively supported.

That said, you can do this:

Good luck and have a nice day!

Nick

Oh, I thought the requirement was 5.6 or higher, not precisely 5.6!
I’ll try downgrading.

That’s not the main problem. Over 70 modules are open source and don’t require Zend. The issue is that our mirror servers don’t support php 7 being passed to them.

Hi Andrew!

I know…

https://issues.freepbx.org/browse/FREEPBX-14777

I am sorry, this was my interpretation of someone close to the project comment when he was asked why not design FreePBX for PHP 7…

As this person is very much in the know I thought that is answer that it had no Zend support meant that it was the main problem…

:wink:

I knew about the mirror problem which is the problem he is facing right now but I thought that until a solution was found (or applied if one has already been found) to the Zend Guard problem there would be no active PHP 7 support.

Do you remember the thread when someone was reading contempt in my “Have a nice day!”'s? I certainly do and it was a thread about roughly the same thing…

Have a nice day!

Nick

1 Like