retrieve_conf won't run as asterisk user

OK, installing FreePBX/Asterisk has been absolute torture so far and I’ve come across yet another issue I can’t figure out. The asterisk user can’t run retrieve_conf for some reason but root can. retrieve_conf is owned by asterisk:asterisk and, since root can use it, I assume all the config files and stuff like that is set up. At this point, my brain is just so fried that I can’t think anymore. Could someone please give me a hand?

; AMI - Asterisk Manager interface
; FreePBX needs this to be enabled. Note that if you enable it on a different IP, you need
; to assure that this can’t be reached from un-authorized hosts with the ACL settings (permit/deny).
; Also, remember to configure non-default port or IP-addresses in amportal.conf.
; The AMI connection is used both by the portal and the operator’s panel in FreePBX.
; FreePBX assumes an AMI connection to localhost:5038 by default.
enabled = yes
port = 5038
bindaddr =
displayconnects=no ;only effects 1.6+

secret = ]4r:Wv:lv#4ft|N
read = system,call,log,verbose,command,agent,user,config,command,dtmf,reporting,cdr,dialplan,originate
write = system,call,log,verbose,command,agent,user,config,command,dtmf,reporting,cdr,dialplan,originate
writetimeout = 5000

#include manager_additional.conf
#include manager_custom.conf

Copy and paste the contents of


You need to change the secret back to amp109. Don’t try to be creative and use whatever you put there.

Then dont install dahdi. These are asterisk problems you are running into now. We are talking about FreePBX here. FreePBX runs as a manager to asterisk.

If you want to use dahdi then you need the kernel sources. This is true. This is how it’s always been. But like I said you dont have to install dahdi or libpri.

No, it doesn’t work. I get to compiling dahdi and it complains that it can’t find the kernel sources when kernel-devel is installed.

Will the manual install work for 6.4? I can only install 6.2 on my VPS and when I update yum, it upgrades to 6.4.

Well then start over and do it manually. Many people do it manually every year and it works fine for them.

The script for 6.4 does a bunch of stuff then just stops with no real information telling me what to do next, what went wrong, or where to go from here.

–2013-06-21 02:44:02--
Connecting to||:80… connected.
HTTP request sent, awaiting response… 200 OK
Length: 2528 (2.5K) [text/plain]
Saving to: âMOTD.pyâ

100%[====================================================================>] 2,528 --.-K/s in 0s

2013-06-21 02:44:02 (229 MB/s) - âMOTD.pyâ

Moving to Next Step

[[email protected] tmp]#

I can see how that can be construed as mean. I meant “if you still want to cry and rip and tear your hair out” then I will be here to help in any way possible. I meant it as slightly humorous. Sorry for the misunderstanding.

how professional

I can’t use the FreePBX distro because it’s going on a VPS that doesn’t allow me to install custom ISOs. I think I’ve attempted that script, as well, and it failed, but I’ll give it another shot. Where can that be found?

It needs to be CentOS 6.3 or 6.4:

If that doesnt work we have this:

and if you still want to cry then come right back and I’ll walk you through it.

Well first off, you can use the distro above.

if you want to install on top of vanilla cent os then we have a script that will turn that into the distro automatically

I don’t know who maintains the powerpbx guides. We certainly dont.

Let me know what you want to do. we have freepbx offical guides to all of these things which I can link you to.

I used this guide because there were multiple comments at the bottom saying it worked. I’m not having as much luck, but I’ve gotten further with this one than anything else I’ve tried.

What guide did you follow when trying to install FreePBX manually?

I’ve gotten things installed, but nothing can connect to the manager. Are there logs anywhere that will be more descriptive as to why?

I’ve done that and made a couple extra modifications to the process. I configured asterisk with --disable-asteriskssl because it’s throwing errors and I just want to get it installed. I also had to install the sqlite-devel and php-posix packages. I’m now receiving the following error when I run amportal a ma installall

bad magic number for object 0x2b7c5c000b88. Object is likely destroyed.

That is not from our code.

The majority of your issues seem to stem from your compiled or binary packages. Whether that would be php/apache/asterisk/mysql it’s something we can’t control and it sounds like it’s host related because you dont have the properly matching kernel sources…etc. Who knows. Once you get those working correctly then we can help you with FreePBX issues.