retrieve_conf failed, config not applied

I had completely forgotten about an EARLY FreePBX 13 Alpha machine that I setup to give the software an early test. I logged in today for the first time in 73 days and did a yum update and updated the modules a few times over.

I am not able to apply the config. The error I am getting:

    exit: 1
Whoops\Exception\ErrorException: Invalid argument supplied for foreach() in file /var/www/html/admin/modules/digium_phones/classes/digium_phones.php on line 102
Stack trace:
  1. Whoops\Exception\ErrorException->() /var/www/html/admin/modules/digium_phones/classes/digium_phones.php:102
  2. Whoops\Run->handleError() /var/www/html/admin/modules/digium_phones/classes/digium_phones.php:102
  3. digium_phones->cache_core_devices_list() /var/www/html/admin/modules/digium_phones/classes/digium_phones.php:47
  4. digium_phones->load() /var/www/html/admin/modules/digium_phones/classes/digium_phones.php:36
  5. digium_phones->digium_phones() /var/www/html/admin/modules/digium_phones/
  6. digium_phones_conf->digium_phones_conf() /var/lib/asterisk/bin/retrieve_conf:494

FreePBX 13.0.1beta3.25 is what Im updated to. I ran fwconsole chown just because that has fixed me a few times in the Alpha / Beta.

I tried a fwconsole ma uninstall digium_phones and if I leave it uninstalled I get the following error (and the original error once I reinstall)

exit: 255
PHP Fatal error:  Cannot use object of type DB_Error as array in /var/www/html/admin/modules/manager/ on line 71
Whoops\Exception\ErrorException: Cannot use object of type DB_Error as array in file /var/www/html/admin/modules/manager/ on line 71
Stack trace:
  1. () /var/www/html/admin/modules/manager/

You need to reinstall manager.

fwconsole moduleadmin uninstall manager
fwconsole moduleadmin install manager

Basically you have a garbage version of manager. You would have only gotten this if you installed a long time ago. Which you did.

digium_phones will not work until Digium fixes it.

I don’t use any digium phones so Im ok with them not working.

I had to uninstall some dependencies to uninstall the manager but I was able to get it to uninstall / reinstall. But Im still stuck with the same error message. Even with manager and the dependencies uninstalled I still got that. I also uninstalled digium_phones and then I was able to Apply Settings!

But once I reinstalled manager and the dependencies I’m back to getting errors.

exit: 255
Unable to continue. Missing argument 7 for manager_add(), called in /var/www/html/admin/modules/cxpanel/ on line 1655 and defined in /var/www/html/admin/modules/manager/ on line 193

I wouldn’t be out too much if I just have to toast this. I had registered the machine but it would be reinstalled on the same machine.

Your next problem is with cxpanel. Uninstall that one!

cxpanel was one of the packages that depended on manager. So I have uninstalled and reinstalled that.

But you are right - with cxpanel and digium_phones uninstalled I can apply configuration.

1 Like