Restricting Caller ID "CLIR" on outgoing calls

I’m using Current PBX Version:15.0.16.20, Please let me know how to make outbound calls with CLIR / FROM : Anonymous.

Thanks !!

Ask your provider if they allow it. If they do, ask them how they want it sent to them.

Hi sorvani,

Thanks for your reply !!
This is a test setup, where we need to check these settings where we want to test CLIR

Example:
From: Anonymous sip:[email protected]>;tag=XXXX
P-Asserted-Identity: “DISPLAY NAME” sip:[email protected]

we would like to have some CLIR on set of extensions, which is supported by provider as well but we need to send a valid number on PAID. I have tried to make changes on outbound CID parameters on extension but still calls sent out with number on FROM and PAID. need to send calls with anonymous on FROM and valid number on P-AID for screening. Please suggest what changes required on asterisk pbx

I have tried to change outbound CID on extensions/trunks/outbound routes but nothing works for CLIR. can anyone help on how to send the calls in mentioned format please

With Outbound CID for the extension in the correct format:
"hidden" <+44xxxxxxxxxx>
post what you do see sent in the INVITE.

Hi,

Scenario 1: Applications --> Extensions --> Outbound CID “hidden” <353xxxx>
FROM : “IRL” sip:[email protected];tag=
P-Asserted-Identity: “IRL” sip:[email protected]
Result : Call reaching to termination with default CLI

Scenario 2: Connectivity --> Outbound routes --> Route CID “hidden” <353xxxx>
Override Extension checked Yes
From: “IRL” sip:[email protected];tag=
P-Asserted-Identity: “IRL” sip:[email protected]
Result : Call reaching to termination with default CLI

Scenario 3: Connectivity --> Trunks --> Hide CallerID (Yes) & CID Options : Force Trunk CID
From: “IRL” sip:[email protected];tag=
P-Asserted-Identity: “IRL” sip:[email protected]
Result : Call reaching to termination with default CLI

Scenario 4: Connectivity --> Trunks --> Hide CallerID (Yes) & CID Options : Force Trunk CID
From: “IRL” sip:[email protected];tag=
P-Asserted-Identity: “IRL” sip:[email protected]
Result : Call reaching to termination with default CLI

Scenario 5: Connectivity --> Trunks --> Hide CallerID (No) , Outbound Caller ID : “hidden” <353xxxx> & CID Options : Allow/Force Trunk CID
From: “IRL” sip:[email protected];tag=
P-Asserted-Identity: “IRL” sip:[email protected]
Result : Call reaching to termination with default CLI

Could you please suggest on how to fix the parameters to test CLIR and to include privacy:id on INVITE
From: Anonymous sip:[email protected]>;tag=XXXX
P-Asserted-Identity: “DISPLAY NAME” sip:[email protected]
Privacy:Id

Ignoring the CLIR aspect, something is fishy here. Outbound CID does not have an initial + but the From header has one, so it was likely overridden somewhere. Confirm that your Outbound Route does not have Override Extension set, the trunk has Allow Any CID set, the trunk settings do not have From User (pjsip) or fromuser (chan_sip) set, and that you haven’t set anything at the provider that would force a particular CLI.

IMO you should troubleshoot by first getting Outbound CID to work, sending a CLI other than the default. Once that’s working, if “hidden” still doesn’t work, post new details.

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.