Restore (to a new system) not enabling voicemail for extensions

Using the newest Backup & Restore module ( Everything else seems to restore properly including recordings and CDRs but voicemail accounts that were previously enabled are disabled with the password and email adress removed. Of course this results in bad destinations.

Any suggestions?

Did you include the /etc/asterisk directory in your backup. voicemail information is all stored direct in /etc/asterisk/voicemail.conf and not stored in the database.

I’ve tried the following in this order:

Did a backup selecting Full Backup, retored dragging over Full Backup -> voicemail not enabled on the one test extension on the system.

Did a backup selecting Full Backup and Voice Mail. Restored the same way, same result.

Backed up both Full Backup and Voicemail. Restored both Full Backup and Voice Mail. Same result.

Deleted the extension from the new system and tried the same way. Same result.

Noticed this during the restore:
Restoring files…
/bin/tar: ./etc/freepbx.conf: Cannot open: File exists
/bin/tar: Error exit delayed from previous errors
File restore complete!

I cant read whats in that file so I copied it to my PC and deleted it from the system. Tried restoring again and now get errors:

“Error verifying uploaded file!” when uploading the backup from my PC and
"Invalid backup for or undefined error" when using the one I saved locally.

Tried adding the tar file back in and get those errors still. Guess I’ll have to delete the system and start over.

Is this a bug?