Restore don't work 2.10 (32bit)

I have made a new distro install (32bit) and cant restore any backup.
Even when I make a new backup (works fine) from the new empty system (added 1 extension to check) I cant restore.
After selecting the file I press Go! than it dissapear, no errors, no status, nothing happend to the configuration.
Tried Backup & Restore and same result.
Tried with 3 computers with IE and chrome
In older versions (2.9) I could choose what to restore (from a full backup), in 2.10 it gives no choses.
Also cant find a logfile to see what is happening after pressing Go!.
Can someone try to make a backup an then restore it on
It’s a new install (old pc) so I can try-out any suggestions before I reinstall our normal voipserver.

Can you send us screen shots of what you are talking about. I have restored 15 plus systems on 2.10 already

Can I send them by email or is there an option I cant cant see?

Make sure the file you are uploading can be unzipped and unpacked. I had an issue in which I uploaded a file to the system and the backup module looked like it was failing to restore, manually untarring the file revealing it was corrupted upon upload.

I have add an extension on the new empty server and made a backup and opened it with 7zip, seems ok, but cant restore.
In 2.9 you could choose which parts from a full backup you want to restore, I dont get that option in 2.10 is that right?
After selekting the backupfile I see some info about the file and the only option is Go or Download.
I made some screenshot