Restarting Freepbx

How do i restart freepbx, i have tried check the restart option from the web page but i coudnt get to locate it. i have also tried with putty but the credentials says they are wrong. Any assistance will be highly appreciated

From the web interface, you may have Admin → System Admin → Power Options → Reboot.
If not, it may have been disabled by the administrator for the account you are using, or the system may not have System Admin installed.

If you don’t know the root password, you’ll need to boot into single user mode to set a new password.

You didn’t say anything about your system, so here is some general advice: If it’s a local, bare-metal server, you must connect a monitor and keyboard and reboot it with the power switch. If a local virtual machine, the virtualization system will have tools to shut down and bring up the VM and will provide a virtual console. If cloud, consult the cloud provider’s instructions for accessing a virtual console.

Here a a guide for root password recovery in CentOS: How to recover your lost root password in CentOS . There are many others. If your FreePBX was not installed from the Distro, it may be using a different OS; that will be obvious when you first boot and you’ll need to find instructions for that OS.

Once you have a known root password, you can log in from the console and run
fwconsole reload
to have Asterisk reload configuration changes, or
fwconsole restart
to restart Asterisk from scratch, or
to reboot the entire server.

You may also be able to log in as root with Putty, but it’s common (and more secure) for systems to be set up to disallow root logins using only a password. Usually, you would set up RSA authentication to log in. Or, you can set a password for a non-root user, log in as that and then run sudo to perform root actions. Or, you could edit /etc/ssh/sshd_config to allow root logins.

Are you buy chance using Vultr virtual machines? I’ve noticed with mine that they don’t respect the reboot command from within FreePBX. It’s not a priority for me since I can easily restart the systems in the Vultr dashboard so I haven’t looked into it further. But I have seen that issue.

@ashcortech I’m using Vultr and did not recognise this issue. It’s good to know :slight_smile: thanks.

@shahin can you give it a try on one of your systems and see if you can confirm my experience? Like I said, haven’t really had the time to dig into it.

I’ve always had that issue with Vultr. When I want to restart the system, I do fwconsole stop and then log into Vultr to restart the instance. The reboot command will not do the job of an actual hard restart.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.