Rest Phone Apps

I have installed the apps, purchased a license and have tried to get the parking function working.

I have been unsuccessful.

I have a yealink T42G and T48G
Running Piaf Blue
Asterisk 13.1
FreePBX 12 with all latest patches.

Can someone point in some areas to trouble shoot. I have even loaded the latest version of firmware v73 on the phones and tried older versions. Same thing.

I can get a manual function to work via xml browser.

My freePBX status page shows restapps.php stopped.


Are any of the RESTAPPS usable? Or specifically just Parking you are having trouble with?

currently i am just working with the parking as this is the main feature I purchased the EPM and phone apps for.

none of the other apps are functioning either.

There is one error that the Isymphony will not install 3.1.8 because manger is missing.

I tried installing and using Phone Apps on PIAF a year ago when we were first launching them with no success, we made offers to that project to provide them licensing to test and configure their Distro so that it would support the apps, but had no takers. Unfortunately at this time Commercial Modules are not officially supported on that Distro, as they don’t have all of the dependencies, or configurations enabled to support some of the functions. You may be able to play around with the configuration to get it to work, I suspect there may be some .htaccess files that are the issue, but you would have to dig around yourself or get some help from the Piaf Distro maintainers to figure out where those bodies are buried. The phone apps will work fine and are supported on AsteriskNow and the FreePBX Distro.

Thank you for your reply. How about some assistance with the list of the various “dependancies” and configurations that are required. I am absolutely fine to sort through and find the issue and report back

I think it’s going to be somewhere in the .htaccess rules on PIAF, but not really sure. I played around with it a bit a year ago, but haven’t had time since then, and I could be completely wrong about that. The rest apps create URL’s that you can see in your config files for your phones, look at the URL’s, and start narrowing down the folders, ports, permissions , iptables rules and .htaccess rules on your box. Wish I could be of more help, but I rarely look at PIAF anymore, and my time doesn’t appear to be getting anymore available for tinkering. If you want to reach out to someone with write access to the PIAF Distro, that knows the ins and outs, I can get them a license to work out those settings for you, and the rest of the PIAF users. (It still wouldn’t be officially supported,mind you as the developers wouldn’t be able to focus outside of a controlled environment, but could keep you from having to do a reinstall using the FreePBX Distro, if you don’t want to go that direction.)

ok, switched to the freepbx bistro. 6.12.65. Installed the latest patches so that its version 24.

Rest Apps not working either.

So clearly, there is an issue.

Where do I look?

Phone Firmware possibly… you can open a commercial module support ticket from the support system in the portal, and someone can take a look.