Rest Apps Voicemail aastra 57i not working properly

I’m running the freepbx distro 5.211.65-15 with aastra 57i phones with firmware version and bootRom I have bought the rest apps and endpoint manager commercial modules and have upgraded the modules to the latest version available. I have configured the phone to have a voicemail button that uses the voicemail rest xml app. I have 2 issues that I haven’t been able to resolve. The biggest issue is that when I press play, it beeps but never actually plays the voicemail message. The second issue is that when I delete a message it takes forever for the light to stop blinking and the voicemail icon to disappear. Any help would be greatly appreciated.

Can’t help with issue one. Issue two is probably fixable by navigating to Settings, Voicemail Settings, Settings, and enabling pollmailboxes and setting the pollfreq to the max number of seconds you want to wait for the LED to respond.

I checked and poll mailboxes is set to yes and the frequency is set to 30. I have also tried applying those settings directly to an extension to see if that made a difference and it has not.

So you’re saying that pollfreq is 30 but it takes longer than 30 seconds for the MWI light to clear?

Yes, The pollfreq is set to 30 seconds but it is taking longer than 30 seconds to clear. If I dial *97 from my phone it clears instantly. But it doesn’t seem to clear by itself.

Try and set it to 10 and see how fast it clears. As far as the beep only I can not replicate it. @qwell any ideas

@tonyclewis it only clears if I dial *97 from my phone. I upgraded the firmware on my phone to and BootROM is It didn’t make a difference. Still can’t listen to voicemails from the phone. I went in the the CLI and looked at the output when I tried to listen to a voicemail. I see this error. pbx.c:9486 ast_pbx_run_app: No such application ‘VoiceMailPlayMsg’. Is there a place to get the VoiceMailPlayMsg app? Also, on the notification not disappearing, I set polling to 10 makes no difference. The voicemail notification pops right up when a new voicemail comes in, so I believe it is polling, but when I hit delete, the notification remains. I do know that it actually deletes the message, cause if I login by dialing *97 it says I have no messages.

What version of Asterisk. I believe you need to be on 11 or newer for that feature.

I’m on version that may explain why I can’t listen to voicemails.

@tonyclewis I upgraded to asterisk 11.2 and I can now successfully listen to voicemails on the phone. However, the polling issue still remains. Any thoughts on how to further diagnose what the problem is? i’ve set the polling interval to 10 and it refuses to update. I can restart my phone and it still shows the voicemail notification, I can hit the voicemail button and it shows there are no voicemail, but the notification is still there. However, if I dial *97 from my phone and login (have to login) the notification will disappear.

OK glad that solved your playing issue. As far as MWI that is not something we control of do anything special on. I bet the samething happens when you remove a voicemail through ARI in FreePBX. The polling inside asterisk is to watch the voicemail system and see if anything outside of asterisk has changed anything with voicemail.

I would start by looking in your voicemail.conf and vm_general.conf files and see what they show for polling.

Okay, for whatever reason the pollmailboxes=yes and pollfreq=30 where not showing up under the general section in my voicemail.conf file. They were set on the specific extension I was testing but, I guess that have to be set in the general section. When I went to voicemail admin, the settings were correct, but I went ahead and submitted and applied config, then the settings appeared in the general section of the voicemail.conf and it is working now. Thanks for the help.