REST apps on Aastra 6867i not working correctly


I just got two new Aastra 6867i handsets. So far I love them, but I am having a couple issues with the REST Apps.

I’m using the commercial End Point Manager to program the phones.

Issue 1: I’ve configured one of the softkeys for voice-mail. I have confirmed by looking at both the config file in the TFTP directory and the phone GUI that the proper URL is being programmed to that soft key. If I copy and paste that URL into my browser it pulls up my messages.

However, when I hit the button on the phone it does nothing. No errors, no response, nothing. I’m using the latest firmware in the EPM as well.

Issue 2: I’ve configured one of the soft keys for one of my conference extensions. When I select the extension and hit dial to connect to the room it will connect, I hear the prompt for my pass code, but when I enter the code none of the digits are registered. This only happens if I attempt to join the conference from the Softkey tied to the REST app. If I dial the conference manually, it works fine.

This one really has me scratching my head. Any help you can provide would be greatly appreciated.

1- I have not ever tested that app on a top soft key. Can you test it on a lower key and see if it works?

2- This is a bug in the Aastra newer firmware that is not passing DTMF correct from XML apps. We have already opened bugs with them on this and waiting for a fix. You will also notice this with transfer to VM and things like pause/unpause in voicemail app as they all use DTMF through XML.

Thanks for your quick response Tony,

I have tried putting it on a lower key and can confirm the same issue. I wonder if this is also some sort of firmware bug.

If I roll back to a previous firmware, will it correct issue 2? If so can you suggest which one to roll back to? I’d be happy to try that and report back on issue 1 as well.

We have not found a firmware it works on yet. Sorry.

As far as VM does not seem like a firmware bug. What do the apache logs show when pressing the button?

Well that’s a bummer on the firmware. Hopefully they get that figured out soon.

I checked the apache logs, nothing is being logged at all. I’ve verified when I use other XML apps that there are log entries being written.


So when trying one of the top keys it does nothing and logs nothing in apache.

When using a lower key, it does nothing, but it does log something in apache:
::1 - - [11/Jun/2014:12:45:13 -0600] “GET /rest.php/rest/voicemail/mailboxes/1212 HTTP/1.1” 200 224 “-” "-" - - [11/Jun/2014:12:45:12 -0600] “GET /applications.php/voicemail/main?user=1212 HTTP/1.1” 200 20048 “-” “Aastra6867i MAC:00-08-5D-41-51-93 V:”

Crap I totally missed the 6867. I was thinking 6757. My bad. So the new 686X series phones are very new and have some issues with XML that Aastra has not 100% worked out. Its missing features and has some catching up to do with the 67XX series still.

Ahh the price of early adoption! I’ve used the 67XX series for several years, but this new series is a lot more aesthetically appealing in my opinion. I just hope the functionality catches up soon. In your opinion is this something they are actively working on, or does it seem like it is on the back burner for them?

Its hard to say. I am told by the folks in Mitel that they are going to keep actively working on the XML stack for all phones including the 68X series.

Let me see if I can track down the specific bug on this or not.

How are the Yealink phones with XML apps? I’m just a creature of habit. I’ve always used Aastra desk phones, so I’ve just stuck with them. Some of the newer Yealink phones look pretty slick too, I just don’t want to invest money in them if they are problematic.

Yealinks are buggy also. The 4X series have lots of little quirks in the XML and globally they have quirks they are still fixing like never being able to exit cleanly or go back in a app.

The Digiums work awesome.

So if we want things to work well are we still stuck with the 675X series from Aastra? And how are the Digium phones with the scripts?