Res_pjsip.c:4261 endpt_send_request: Error 171060 'Unsupported transport (PJSIP_EUNSUPTRANSPORT)'


#1

What does the message in the subject line mean? I tried to change some extensions from SIP to PJSIP but as soon as I apply the changes, on all PJSIP extensions I get these types of errors:

[2019-11-12 05:05:18] ERROR[3957]: res_pjsip.c:4261 endpt_send_request: Error 171060 ‘Unsupported transport (PJSIP_EUNSUPTRANSPORT)’ sending NOTIFY request to endpoint 1100
[2019-11-12 05:05:18] ERROR[1200]: res_pjsip.c:4261 endpt_send_request: Error 171060 ‘Unsupported transport (PJSIP_EUNSUPTRANSPORT)’ sending NOTIFY request to endpoint 1102
[2019-11-12 05:05:18] ERROR[1201]: res_pjsip.c:4261 endpt_send_request: Error 171060 ‘Unsupported transport (PJSIP_EUNSUPTRANSPORT)’ sending NOTIFY request to endpoint 1104
[2019-11-12 05:05:18] ERROR[3958]: res_pjsip.c:4261 endpt_send_request: Error 171060 ‘Unsupported transport (PJSIP_EUNSUPTRANSPORT)’ sending NOTIFY request to endpoint 1103

When this happens those extensions become unavailable until Asterisk is restarted. What does this message mean, and is there some way to stop whatever is causing it? Changing the extensions back to CHAN_SIP fixes the problem, but then I’m not using PJSIP.


(Joshua C. Colp) #2

It means that the transport needed to send the MWI NOTIFY is not available. Did you do a reload? If so this can sometimes happen on systems if transport reloading is enabled (which is why Asterisk defaults such functionality to off and why going forward in FreePBX it defaults to off). This option is “allow_reload” on the transport, but as I do not work on FreePBX I do not know where it is.


#3

Thanks. I found it, it is the very first setting in the Chan PJSIP Settings, in the “Misc PJSip Settings” section, and is called “Allow Transports Reload”. It was set to yes, so I changed it to no and that fixed the problem. If you mouse over the question mark icon, it actually says, “Allow transports to be reloaded when the PBX is reloaded. Enabling this is not recommended, and may lead to issues.” But for some reason it was originally enabled by default nonetheless. So, good to hear it will be disabled by default going forward.


(system) closed #4

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.