Requirecalltoken problem in an IAX trunk(s)

The system is a FreePBX Distro version 6.12.65-25 I replaced an older asterisk based system that was connected to like systems for some time. They had no problems calling between all three locations until I replaced the one system with a FreePBX system. I have the IAX trunks created and I can call from the Freepbx to the other system and it is fine. When the others call to me they get a busy signal and in the logs I get this:

[2015-05-20 15:34:11] ERROR[2007] chan_iax2.c: Call rejected, CallToken Support required. If unexpected, resolve by placing address in the calltokenoptional list or setting user baygladwin requirecalltoken=no
Here is what I have tried:
added requirecalltoken=no in the Asterisk IAX Setting
added requirecalltoken=no in the Peer and User details for the trunk

So at this point I do not know where to go. Can anyone help me out here?


Remove personal details (IP, username).

Also, have you tried placing that IP in the call token optional list?

Hi Overkill,

Yeah I messed up on that IP and username. Oh well, I 'll remember next time. Where is the call token option list? I have never heard of that before. I’ll google it and see what I come up with.


In your IAX config: (from

CallToken Support required

if you get
Nov 2 15:58:47 ERROR[823]: chan_iax2.c:4040 handle_call_token: Call rejected, CallToken Support required. If unexpected, resolve by placing address in the calltokenignore list or setting user iaxhorst requirecalltoken=no
Since AST-2009-006 there is a check for a call token performed. Older clients (e.g. Asterisk 1.2 before 1.2.35) don’t support call tokens, so there is a parameter

per peer or
calltokenoptional =

per subnet.

So I can put that in the peer / user details? I put requirecalltoken=no and that didn’t work I will try the other entry


Here is my peer details:

calltokenoptional=IP of the distant office

User Details

calltokenoptional=Ip of the distant office

I still get the error in the logs. Could the other systems be so old that they won’t work? I think they might be Asterisk 1.4 or 1.6

Your system is expecting the call token, and isn’t getting one. In the IAX.conf file you should set calltokenoptional=IP

As soon as I can access the iax.conf file I will put that in. Won’t that get overwritten the next time I create an IAX trunk?

To be honest, I’m not sure. Maybe it can be added with the GUI?

I have added it everywhere I can think of in the GUI. In the User / Peer Details and in the Advanced IAX settings. Can you think of anywhere else?

I haven’t used IAX before, so no :frowning: Maybe a dev or @dicko can weigh in?

Juat read and impliment it to suit.

Thanks Overkill & Dicko