Reports not updating

Well i am stumped my call records end on 11/11/2008.

since then no updates.

Anyone advise how i should even start debugging this problem?



what did you change on that date?

Think it was the day before i had to do a reinstallation to put in a patch on zaptel to allow for CID.

should i drop the database and re-install again, you know make make insall etc?

don’t really want to aS THE system works at the moment. except for call logging.

in fact i have ironed out most of the bugs in/on it.

one of the common reasons can be that you stopped asterisk and started it as root instead of using the amportal script.

If you re-compiled did you recompile asterisk to a newer/older version and forgot to match the asterisk-addons? as without them the CDR will not work.

yes i did it as root, amportal script now you lost me?

no same versions.

asterisk and FreePBX should be started properly to do that use amportal stop and amportal start. If asterisk is running as root it can cause problems. It needs to run as the asterisk user.

Now how do i solve the original question.

I may have got it wrong now how do i fix it?

Anyone advise how i should even start debugging/FIXING this problem?

I have now tried dropping and recreating the asteriskcdrdb database and permissions.

that did not help but it did clear call records (obviously)

i also tried amportal stop and start (we all make mistakes and i never saw that one till now)

It seems the database is not getting updated.

anyone any ideas what i should try next?

asterisk was not using mysql it was using cvs only.

re-run the asterisk addon’s and used makemenuselect to ensure mysql add on was added, cdr now working (after a full server reboot)