Reports and CRD with FreePBX 2.4 and Asterisk 1.4.18

I have this problem with the reports :

The ANSWERED call are well in the cdr, in the database and in the freepbx reports interface.

cdr example (one line) :

# "2701","2701","006XXXXXXXX","from-internal","""tel2701"" <2701>","SIP/2701-092955d8","Zap/3-1","Dial","ZAP/g1/06XXXXXXXX|300|","2008-02-20 10:15:24","2008-02-20 10:15:32","2008-02-20 10:15:33",9,1,"ANSWERED","DOCUMENTATION","1203502524.69","" But for the NO ANSWER call, I've got this (two line) : # "e1","2701","s","fromrtc","2701","Zap/3-1","","","","2008-02-20 10:15:46",,"2008-02-20 10:15:54",8,0,"NO ANSWER","DOCUMENTATION","1203502546.72",""

“2701”,“2701”,“006XXXXXXXX”,“from-internal”,""“tel2701"” <2701>",“SIP/2701-092955d8”,“Zap/3-1”,“Dial”,“ZAP/g1/06XXXXXXXX|300|”,“2008-02-20 10:15:46”,“2008-02-20 10:15:54”,8,0,“NO ANSWER”,“DOCUMENTATION”,“1203502546.71”,""

Why is there this first line ???
So I see two calls in the reports and the first one has wrong values (DST=s)

Does it come from my asterisk installation ? or from my freepbx configuration ?

Thanks for your help.

The ‘s’ value in the ‘dst’ field typically comes from nagivation from 1 context to another. Like navigation through an IVR. In many cases, the ‘dst’=‘s’ cdr can be ignored.

S can also come from any part of the dial plan where there is not a specific inbound route to handle something. The most common one is a inbound any/any rule. As it can also be seen in a any/any rule that forwards to a specific extension or ring group for example. It is true that most people have a any/any rule that forwards to a IVR.

Thank you for your answer.

Where does the fromrtc context come from ? I have this problem when having an internal or external call with my “manually install”.
I tried again an old iso version (asterisk 1.4.13 with freepbx 2.3.1) and don’t have the problem…

I don’t see any difference between the two outbounds route and trunks configuration…

I would be happy if someone has an idea to solve my problem:-)


I come back with the same problem. I thought I “solved” Id by adding " AND dst!=‘s’ " in the sql query in the php source…

It works when I manually call a phone, but when using the manager originate action, the dial status is always “ANSWER”

When I look at the CDR, I see this for an “NOT ANSWER - ORIGINATE CALL”, The dial status is different between the 2 lines :

# "e1","2701","s","fromrtc","2701","Zap/3-1","","","","2008-02-20 10:15:46",,"2008-02-20 10:15:54",8,0,"NO ANSWER","DOCUMENTATION","1203502546.72",""

“2701”,“2701”,“006XXXXXXXX”,“from-internal”,""“tel2701"” <2701>",“SIP/2701-092955d8”,“Zap/3-1”,“Dial”,“ZAP/g1/06XXXXXXXX|300|”,“2008-02-20 10:15:46”,“2008-02-20 10:15:54”,8,0,“ANSWER”,“DOCUMENTATION”,“1203502546.71”,""

I delete the first line (dst=s), so the dial status is always ANSWER…

Do anyone have a working solution with call center, originate and the freepbx reports ???

Thanks for you help

It seems the originate command is really not freepbx friendly. Im still trying to figure out exactly what problems its causing and how to fix them