Replication of servers for backup

I’m very new to Linux and using FreePBX 2.9 and have two Dell 1850 machine servers and using 1 as the primary and the second as just a backup, we are using SIP trunks. My question is how to use rsync to make a complete backup of server 1 to server 2 in case of a crash without user intervention. I have found this article on Trixbox but having a problem getting it to work for me, can anyone help a very newbie with the right commands.

take a look at the backup module. You can have server a’s data dumped to server b every so often but I don’t think there is a way to make it start automatically (at least on its own just with the backup module) on server b. Having backups on server b is a great idea and this assumes there’s at least access to the servers so in the event of server a going down, someone can complete the setup on server b.

If you’re new to freepbx and linux, failsafe is not really the best area to study right away. Do you know a lot about dhcp and hostnames?


I agree totally with asterisk21st. We use the FreePBX backup module very successfully with backup servers. Our normal configuration is:

  1. Primary and Secondary PBX both running on different IP addresses
  2. Primary config backed up to Secondary box using the FreePBX module and applied
  3. All handsets (using Aastra) have primary and backup proxy and registrar setup
  4. The SIP trunks are configured with primary and secondary IPs so they will talk to both servers

In the event we lose the primary server all the handsets and sip trunks swap over to the backup automatically.


GWalmsley I like the idea of what you are doing, can you provide a little detail or a lot so that I can setup ours the same way, we are using grandstream GXP-2000 phones in our solution, I’m very new to linux so if you can please understand I’m a windows person.

Do your phones allow a primary and a secondary hosts?
Do you have freepbx installed exactly the same way on both server a and server b?
Are the machines on the same or different vlans?
Did you read the article mickecarlsson posted?

I’ve looked at the configuration on the phone and it doesn’t seem so.
Yes both servers are matched and configured the same.
Both servers are on the same network.
Yes and I’ve configured and having it scheduled to replicate every 60 minutes. Just finished with the configuration and it works great.

How are you getting your trunks to work both at the same time?

Thanks everyone for the help, I have gotten the High Availability backup working but the only problem I’m having now is, I have setup a schedule backup to run every 10 minutes to do the SSH backup and works only if I have it run now but if I try to schedule for every 10 minutes it never runs. Any ideas?

ok well I don’t have a recent backup and my FreePBX admin panel crashed while I upgraded php5.1 to php5.3. I have rebuilt the system, did a mysql dump --preserve to backup and restore to the new system.

I have copied all custom asterisk config files.

It had seemed to work it was answering calls just no phones were setup to the new box, so all calls were sent to voice mail.

My concern is, upon updating it would simply just hang after I click confirm. I get the popup with the following message “Please wait while module actions are performed” but nothing happens, I let it run all night (last night) it updated 3 out of 31.

Is there a version table in the database that would mess things up? The old server was at 2.8 and the new one was at 2.8 and got messed up trying to get it to update passed

by the way I am running on the new system I am running a new build of AsteriskNow 1.7 w/ FreePBX updated to

the old system was AsteriskNow 1.6 w/ FreePBX updated to

I have tried updating to 2.9 then mysql dump but upon confirming changes it gave me some errors.

Is there another solution?

Any help would be greatly appreciated,
Thanks in Advance,

You copied the mysql DB but not the AstDB. Resubmit each extension and any follow me.

are you certain you have it set to update on its own and not the “now” button?
Once you do a manual update, it will keep “now” saved until you tell it to run x.

I have tried still no luck, also got all my feilds to show by doing a mysqldump --alldatabases in a virtual machine backed it up using the FreePBX backup module and restoreing it to the new server, some modules were broken, uninstalled those, tried to update and it hanges after updating the first module. Any help would be great.