Replacing +31 in outgoing calls


(Kris Coady) #1

Hi guys,

I’ve been Googling this issue all day but can’t get it fixed. I have FreePBX server with a few Grandstream VoIP phones in the office, situated in the Netherlands. When dialing numbers that starts with a country code it’s not possible to make a call. The phone displays “No dial plan rules matched”.
So I would like FreePBX to automatically replace the “+31” at the start with “0”.

Ive been messing around with Connectivity > Outbound routes > Dial Patterns
and also Connectivity > Trunks > Dialed numbers Manipulation Rules without any succes.

Any help with this simple matter would be highly appreciated.

Thanks,
Kris


(Avayax) #2

Looks like this is your phone that is not allowing the call, not FreePBX.
Check the dial plan rules on your phone.


(France) #3

What I did for my similar case.
Put 00 in Prepend and + in Prefix.
and obviously X. in the pattern

That will create an international number that your dial plan will understand.


(Tom Ray) #4

Are you sure that isn’t a phone error. The phone would have no way of knowing that the dial plan rules didn’t match in the PBX. I’m guessing the Grandstream isn’t programmed to accept + or other patterns.

Phones have their own dial patterns that must be matched in order for the phone to even send the call to the PBX. There is nothing the FreePBX that sends back an error with “No dial plan rules matched” I’m pretty sure that is the phone.


(Kris Coady) #5

Thanks for the replies everyone. It might indeed be related to the Grandstream settings. I’ll go through those and let you know if I manage to fix it.

Thanks again.