Remote SIP extension registers but get message 'Call Failed'

I followed the guide here
and my remote extension registers but when I try to make call I get return message ‘Call Failed’

Now I suspect ports setup because at one point when I changed the SIP Extension configuration on Asterisk from the usual port 5060 for the extension, I managed to make a call even if it had sound only one way, then I tried to play with it some more and now I don’t get any call through but simply get right away the Call Failed message on the remote phone display

I am trying with Aastra 480i which is behind Linskys WRT54GL router flashed with ‘DD-WRT v24 VOIP’ firmware which has Milkfish SER onboard and I don’t think I could register Aastra extension without it

what puzzles me about ports is this - I have a trunk on asterisk connecting me to LesNet DID and that one uses port 5060, now I have two SIP estension and they both seem to require UDP port 5060 to be specified in their configuration, shouldn’t each asterisk SIP extension be configured with different port?

on the remote end the Aastra phone needs port 5060 along with registration IP (I use FQDN having setup dyndns service at asterisk end), if I try different port like 5067 for example, Aastra won’t register with asterisk at all and I don’t get it, I mean I can’t be using just port 5060 for everything can I? of course I have the usual ports forwarded to asterisk (UDP 5004-5082 & 10000-20000)

another confusing factor is that Aastra has Global SIP and Line1 -> Line9 configuration webpages and I have no idea what the Global SIP configuration is good for, I suppose that is simillar to most IP phones out there, I am configuring just Line1

As for the Aastra Global SIP, If you only have one server then put all the server setting into the global settings and define the required values for line1 (user, password). If you have multiple servers and line 1 talks to one server and line 2 talks to a different server then you need to fill in the regisra

So for one server in the aastra.cfg file (or your .cfg) file put
sip proxy ip: your_server_here
sip registrar ip: your_server_here

and in the .cfg file
sip line1 auth name: extension_number
sip line1 password: your_extension_secret
sip line1 user name: extension_number
sip line1 display name: phone_display_name
sip line1 screen name: phone_display_name

If you are doing multiple servers then in the .cfg do

sip line1 proxy ip: Server1
sip line1 registrar ip: Server1
sip line1 auth name: extension_number
sip line1 password: your_extension_secret
sip line1 user name: extension_number
sip line1 display name: phone_display_name
sip line1 screen name: phone_display_name

sip line3 proxy ip: Server2
sip line3 registrar ip: Server2
sip line3 auth name: Server2_extension_number
sip line3 password: Server2_your_extension_secret
sip line3 user name: Server2_extension_number
sip line3 display name: Server2_phone_display_name
sip line3 screen name: Server2_phone_display_name

Per Aastra Support if a phone is connecting to more then one server the sip line? proxy ip and sip line? registrar ip is required for each and every line defined. (yea I have it in writting and it’s also stated as such in the admin manual). But I also know that with all 9133i firmware if the first line uses the same server as the default it will work without defining those lines…

Realize that at the remote phone location if it has a firewall it is also possible that you might need to program a forward for udp 5060 on some router/firewalls.

thx for answering, wasn’t hoping that somebody might answer and so stopped checking after few days

I did as you say, I put Server details in Global Settings page in “Basic SIP Network Settings” section, leaving the “Basic SIP Authentication Settings” empty and filling those details in Line1 page while leaving out the server info there, at least now I have some idea how the Global vs Line settings should be used, thx again

After I did the changes as per your advice it works the same as it worked up to now, that is I get the Aastra phone registered to remote asterisk but in asterisk ‘SIP info’ (see below) it says that ‘Status’ is either Lagged or Unreachable (I suppose the latter when the lagging is even more severe than those 3000 ms) and it is always about those 3 seconds lagged even when I forward the port 5060 to Aastra phone
the pone also keeps unregistering (same as with my previous setting) every few minutes and registering after a minute or so, seems like the registration is not reliable or maybe it unregisters when the laggout gets to big

Name/username Host Dyn Nat Port Status
177/177 90.176.xx.xx D N 5060 LAGGED (2838 ms)

I think it might be this Lagging that results in ‘Call Failed’ message on Aastra phone when I try to call anywhere from that phone, when I try to call Aastra from other working extensions I am told that 'The person at extension 177 is unavailable…

the lagging would seem to be the result of wrong port setting perhaps? here is the full SIP Info

Name/username              Host            Dyn Nat        Port     Status
178                                (Unspecified)     D     N           0            UNKNOWN              
177/177                        90.172.xx.xx        D     N           5060     LAGGED (2838 ms)           
170xxxxx/170xxxxx         N                   5060     Unmonitored   
3 sip peers [Monitored: 1 online, 1 offline Unmonitored: 1 online, 0 offline]

I am not sure about port 5060 since it is being used already for DID registration (bottom entry) and if I used another Aastra phone to register to extension 178 and it would also use port 5060, wouldn’t it create some port conflict? Problem is the Aastra phone doesn’t register with asterisk when I specify port different from 5060 (although I have forwarded to * UDP ports 5004->5082 as well as ports 10000->20000 also UDP

what I am doing is I put asterisk in my place in Canada that has decent internet connection and gave all my family members in Europe IAX ATAs which register to remote asterisk just fine (they all live in different towns), problem is only with SIP phones

I am only considering hardware phones, not software ones, and would buy more Aastra’s 57i CTs if I could make them work as remote extensions, right now I have two 480i CTs and doubt that remote conectivity would be better with the 57i’s

one solution would be to supply each phone with asterisk PC and then remote network these asterisks to the central one but that would mean about $100 expenditure extra above the phone cost (plus three locations do not have ethernet port available for asterisk and that means more expense)
I have not networked * yet, I suppose I could do it but likely not with more than couple asterisks(via IAX trunking)

Without going into a long detailed explanation of how TCP/IP works I simply want to make the point that you are over complicating the issue. If you have 10 computers in an office behind a single IP address and you all go to everyone can see and interact with the web site, correct? That web server is listening on standard port 80, for HTTP services. It handles the multiple sessions quite nicely.

Likewise, Asterisk can handle multiple SIP session on port 5060 quite nicely. SIP does not live quite as well behind NAT as HTTP does. However on the server end, with only port 5060 forwarded to the server you can have as many registrations as you need.

The problem comes on the remote end when you are running multiple phones (endpoints) behind NAT.

On the server end you only need port 5060 and UPD 10000-20000 setup. 5060 is for SIP and the port range is for the media streams (RTP). These ports need to be forwarded to the server’s inside IP address so that all traffic on those points arrives at Asterisk.

Are you running the Proxy on the server end? You should not this could cause serious issues. The Milkfish Proxy is especially problematic as it performs some local call processing.

The purpose of a proxy is to allow multiple endpoints to work at a single remote site. The proxy registers with Asterisk and then the phones register with the proxy.

If you are configuring multiple registrations on the remote phone that could be causing some of the problems. I am not sure what you are saying about ‘5060 is shared with the DID’s’

A little more information on your setup and we should be able to get you going.

“Asterisk can handle multiple SIP session on port 5060 quite nicely.”

good, didn’t know that 5060 will be good for all extensions, good example with http using port 80 for everything, didn’t think of that one
I forwarded whole bunch of SIP ports to asterisk as is usually recommended, it doesn’t hurt anything 5004-5082 (excl port 5038 as it is used for something else sometimes, I suppose) plus RTP range 10000 to 20000

what confused me is that each SIP extension as you set it up in asterisk has one entry in ‘Device Options’ where you specify port - I took that to mean that perhaps if one has more than one SIP extension, one should specify different port for each

I have trunk set up in asterisk for incoming calls from LesNet provider (DID) and that one uses port 5060 - if I look at ‘SIP info’ in asterisk the LesNet trunk is showing there registered on port 5060 - that led me to think that any other regular SIP extension I create in Asterisk should be assigned different port (else why put the provision in each SIP extension to specify port), however now that I think of it I can see that ports can’t be what makes asterisk know which extension to ring when a call comes in… it has to tell by extension number and it either uses port 5060 or it picks some other one if that one is at the moment busy, that’s why it is usually recommended to forward range of SIP ports to asterisk, right? OK that’s settled, I will let my (so far only two) SIP extensions have the port 5060 in extension setup

I only played with ports trying to make them exclusive for each extension/trunk because my SIP remote extension doesn’t work, I started with port 5060 (I think its default port when one makes new SIP extension in asterisk) and if my remote extension would have worked I’d never try to change it

next point: I am not running any proxy at server (asterisk) end, that Milkfish SipExpressRouter (SER) proxy I mentioned is on the router gateway at remote end (it is part of routers firmware) where the Aastra phone is located

to tell the truth, I would dearly not use any Milkfish proxy on the router at those remote locations (when I say remote I mean remote from asterisk location) because I would like to supply all family members with Aastra phones and none of them has any such proxy at their place and the routers they have wouldn’t accept it anyway, ideally I would like to make Aastra phones work without it

this proxy doesn’t register with asterisk, I don’t think it even has provision to enter registration details, the server registration IP (I use FQDN as I have dyndns service at asterisk end) and port is entered in Aastra phone as well as proxy IP which in my case is the router’s IP

Aastra phone has two entries for proxy: one is simply called ‘Proxy’ and the other is named ‘Outbound Proxy’ and I found that I have to fill in both with the same IP (the router’s IP) and port 5060 if I want to have the phone show up as registered on the router/proxy

the function of the proxy as I understand it is to help the phones behind it (on LAN) to be able to get properly accross router’s NAT and get reigstered with remote server, as well as being able to have calls working (two way voice)
if there is more than one phone behind this proxy, the proxy checks if a call is between local extensions and if it is, it bounces the call back to LAN to the called extension, when the called extension doesn’t exist on LAN behing the proxy, it lets the call proceed to remote asterisk (which sits on LAN behind firewall and to which the phone originating the call is registered)

per FreePBX guide here, I edited asterisk’s sip_nat.conf to contain the following lines

(I have dyndns setup with but I also tried with ‘externip=xxxx’ with my current IP wich is dynamic but doesn’t change often and is ok to experiment with as if it was static IP but that makes no difference)
my asterisk installation is PBX in a Flash v1.2 (PIAF) preconfigured from Nerd Vittle (it has Astrisk 1.4 and FPBX 2.41) and he also advises on his website how to properly configure remote SIP extension and he says there to enter the above lines into the sip_custom.conf file (as opposed to sip_nat.conf file that FPBX advises), I tried both, one at a time and also both at the same time (which is what I have now) but it doesn’t seem to make difference

also I don’t have trouble registering tjhe remote phone, the problem is that I cannot make calls, I get ‘Call Failed’ message on Aastra phone and when I check asterisk SIP Info, it shows the registration of the remote SIP extention number with the correct remote IP but it says it is Lagged 3 seconds, sometimes it says Unreachable
when I try to call this remote SIP extension from other working extensions, asterisk tells me ‘the ext # is unavailable’, also in FPBX Panel the remote SIP extension while not completely greyed out (as the other SIP extesion is which is not registered at all, for now I try to make working just one of them) it doesn’t look as brightly lit as the rest of extensions, also on the left where each extension has little white arrow on black background, this remote registered SIP extension has green background, maybe that has to do with the fact that those other extensions are all IAX2 ones

I am quite new to asterisk, maybe you could tell me where I could get pull out of asterisk some technical logs for troubleshooting why this remote SIP extension is lagged (3000 ms on average) and why asterisk has trouble using it

at one point I was able to get one call through but the voice was one way only, it was after I changed port from 5060 to 5064 in the SIP extension setup in Device Options (in asterisk) but that port change might have been just a fluke, a coincidence, that then led me to experiment with port setting in SIP extesions setup in ‘Device Options’ thinking every extension should have unique SIP port there

“If you are configuring multiple registrations on the remote phone that could be causing some of the problems”

currently I plan to register the phone to single extension on asterisk, mind you I was somewhat taken aback by finding out that most of the features of your typical SIP phone are a total waste when one uses it with asterisk, it seems those phones are meant to be used without asterisk registering directly to various telephony providers out there which is what the multiple lines are for if I understand it now - however couldn’t one reigster several lines to several different extensions on asterisk and map those extensions to various trunks, might be simpler than trying to figure how to do it with dial plans which seem to be simple initially but when one starts configuring them one gets burried in their deep logic and looses one’s way in a jiffy

currently I am located at the remote phone end in EU while asterisk server is Canada, I have full control over asterisk though via remote access to PC on LAN where asterisk sits, and I have to say if I didn’t have so much time on hand I would have given up long ago, remote sip extesion is true living hell and telephony geeks nightmare, I was thinking of buying more SIP phones, the Aastra’s 57i but I am affraid to plow more money into this hell hole which it turns up to be, even if I have time on hand I’d rather spend it on other things than endless trying to make the phone work

I have 50% success :slight_smile:

I went into the remote phone setup and on Global SIP settings page I decided to try to have only one SIP proxy, first I tried with ‘Outbound Proxy Server’ only leaving the ‘Proxy Server’ field empty and I didn’t register to server

next I tried with only ‘Proxy Server’ field filed out (leaving Outbound Proxy Server fields empty) and I got registered to asterisk and I got dial tone in receiver and envelope on phone display indicating voicemail which I left for that extension a while back and I knew I got some major progress

however I can only place calls to this remote extension (and I have two way voice), using this Aastra phone to place calls still returns Call Failed message on the phone display and the called exttension doesn’t ring, I don’t think the call goes anywhere or perhaps asterisk doesn’t accept calls placed from this remote extension but allows calls to connect to it, what could be the trouble?

as I wrote in post just above, I filed in NAT info in both sip_nat.conf and sip_custom.conf files in asterisk but doubt that is the culprit in not being able to place calls on this remote extension

also the phone now doesn’t show up in Miklfish SER proxy ‘Phonebook’ which might mean if I had more than one phone behind this router I might not be able to call between them locally but that would be small price in my books, I think maybe the router proxy is somehow blocking the outbound calls but allows the calls from asterisk to reach it

I am more and more doubtfull about this proxy (it might be responsible for all the troubles I have and I will try to get some support on DD-WRT forum) but it looks I need some proxy, perhaps I should just ditch what i have now and see if I can get registered without it or maybe use some public proxy (any advice on that?), however that is what STUN is used for and this phone doesn’t seem to have STUN included in it, at least I don’t remember seeing it in its setup pages, anybody knows some other firmware with proxy for my WRT54GL router?
right now I use DD-WRT v24 VOIP that has Milkfish SER proxy as part of firmware

still I am now upbeat it can be made to work

You are over complicating this. Now I am all for understanding the technology, it makes troubleshooting easier.

However in your case you are making your life very hard. In the time it took you to write this post you could have read a concise guide to SIP and it all would have made sense to you.

Now that is out of the way, here are a few things that should get you back on track.

[]SIP phones are signaled by their IP address, a SIP message is sent to the phone to tell it to ring.
]The range of ports you are speaking of are for streaming media (the voice) portion of the call.
[]With only one phone don’t try and use the proxy in your router
]In the remote phone program the Asterisk servers public IP in the proxy address (and everywhere else)
[]Make sure you have externip and localhost set correct in sip_nat.conf
]There should be a way of turning NAT on in the phone.
I have never tried using a 57i remotely, however I know it supports NAT. To show you how simple this is I have an a Polycom 500 I can carry and plug into most hotels Internet connection. It registers with my server and I am on the phone working remotely!

thx a bunch for this one line “In the remote phone program the Asterisk servers public IP in the proxy address”

that did it, now I can call out as well as receive calls, why on Earth nobody out there gives such advice as you just did

I guess reading the primer on SIP could be done in the time I wrote the post (fortunately I type quite fast plus it makes me think and often I found my problem while typing my posts in past), still I don’t think that would cut the ice, who would have thought to put asterisk public IP (I put in its FQDN) in the proxy entry field

that means I took the Milkfish proxy on the router out of the equation (just disabled it on the router and the phone still works) and probably will be able to use the SIP phones at my various family locations, you made me really happy I must say, it is like magic seeing this work, again thank you so much, I will be buying some Aastra 57i phones soon

I just drank a glass of red wine to your health :smiley:

Glad you got it working.

I appreciate the kind words. Actually the FQDN should have worked. You may have to hard code the DNS in the phone. If you have a static IP this is not as big a problem.

What DNS was the phone picking up? Often since delay is not a big factor it is easier to use a public DNS server such as in the phone config instead of having it pick up the caching DNS that is built into the router. I am not sure why this works but it does.

If the phone won’t resolve the FQDN in the proxy field I would submit that as a bug at Aastra.

Taking the proxy out of the equation was also key. The proxy is only needed for multiple remote endpoints.

Have fun.

yes, I have assigned the phone a static IP and first DNS is router’s IP and second one I put in from my ISP but will put in the public one as you suggest because it makes it more mobile if you take the phone to other locations, the is one I sometimes also use when working with PCs, I might do as you say, use the public DNS as primary instead of the router’s IP, never had much faith in cached DNS

“If the phone won’t resolve the FQDN in the proxy field I would submit that as a bug at Aastra.”

it resolves FQDN just fine, what I was saying I had router’s IP in the Proxy Server field because it said so in the proxy help that’s what should be put in there and I never dreamed of putting in the public IP of Asterisk that is out there on internet, so now I have that asterisk’s FQDN both in the Proxy entry field as well as in Registrar IP field on the phone and it works like a charm

so you are saying that if I had couple or more of these Aastra phones here on this LAN, I’d need to use proxy? I have just tried in my newly gained enthusiasm to configure Line2 on the phone with my second asterisk SIP extension but it didn’t get registered on asterisk’s end, however I should be just fine with one phone per household because these phones have mobile units associated with them (up to four of them per each phone)
I will try tomorrow to hook up my second Aastra phone and see if its Line1 will register to that second SIP extension, maybe the Line2 can’t be used like that

I looked up European time servers now and set the phone up with it but while the phone gets the date right, the time is still taken off Asterisk’s location in Eastern Canada which is six hour off, maybe I may have to set Asterisk to European time region? that’s where most extension will be located, I don’t see any setting in the Aastra phone to make it shift timezone, i thought that EU timeserver would give it European time

anyway, got to go to bed now, will check here later on, thx again

I’ve set up a number of Asterisk/FreePBX systems and never used a proxy yet, I wouldn’t bother with one at least for now.

If you use more than one registration from the same phone, that’s where you may need to use different ports.
As SkykingOH says, the phone is addressed by it’s IP + Port; if you have multiple registrations something needs to identify each individually.

All NTP (time) servers use UTC, it’s down to each client to set the Local time offset, so there should be something in the phone config to set it. If you are using DHCP to configure them, it’s also one of the parameters on the DHCP server (option time-offset).

  • If you are using an embedded server such as an ADSL router, it could be a time setting in that?

ps. On a matter of principle, make sure your RTP config and Port forwarding range starts at 10001 not 10000.
‘Webmin’ uses port 10000, so if this is included in Asterisk/Freepbx there is a chance of calls failing.
If it’s included in the Port forwarding range & Webmin is enabled, it’s a security hole…

Have fun!

Webmin uses HTTPS which utilizes TCP for transport. RTP is UDP the sockets/ports will have no impact.

thx for the comment, re: port 10000, the ‘PBX in a Flash’ installation of Asterisk puts webmin on port 9001
I suppose it is done precisely because people unwittingly forward begining with port 10000, in my case because I had trouble getting the phone working I set it to start at 10000 (I had it @10001 even if webmin wasn’t there just for easy sleeping) because I wanted to have everything as standard as it could be and I will change it back to 10001 now that you mention it
/Edit: read now what master SkykingOH (tadpole) posted while I was composing this post, sounds right, not sure then why would those guys shunt webmin to port 9001

so far I don’t see any time offset in the phone’s setup webpages, I already set asterisk in General settings the Location to my particular country I am at in EU but that has no effect that I can see, no idea why its there

I thought if I pick NTP server in the country I am in it would automatically supply local time, shows you one can’t assume anything

BTW I am using public NTP server, nothing on my router, it must be getting the time off asterisk because I don’t see how it would pick up just the six hour difference which is exactly the time offset btw asterisk location and this remote phone, the time on the phone is the correct time for asterisk location which is overseas

“If you use more than one registration from the same phone, that’s where you may need to use different ports.”

I guess the keyword here is ‘may’

I have experimented and I think I busted the phone, during reboot it came back with display showing registered but was not responsive to handset or buttons or anything and webpage access was cut off, I then powercycled it and now the display just lights up but no info on it, powercycled it several times and still nothing, I don’t see any reset button on it, may have to read the manual now

what I did just prior to this was trying to make the phone register to the second extension on asterisk, on Line2 I input login details for the extension on the phone (auth name and pass) and because that didn’t make the line functional, I changed in asterisk the port for the SIP extension 178 I wanted Line2 on the phone work with and it still didn’t work, so I also entered asterisk login details in the phone in Line2 section (Proxy and Registration Server info which was the same as that I have in Global Settings page)

Line2 then magically began to work just fine, on asterisk end it showed as registered and I could make calls in and out… I then decided to change the extension port in asterisk back to 5060 as changing it to something else was likely not needed and probably wasn’t what made the second line on the phone to work… I did the change and also decided to reboot the phone to see if it will again register to asterisk on both lines but upon reboot the phone got stuck and now it looks like its dead, just the display is lit and at one powercycling it showed all it is capable to display (like when you put on too much contrast on display) but it shows no functionality whatever, its piece of plastic with lit led display

Aastra sold the phone with useless power supply adapters 48V DC and they both burned out in EU when I connected them to step down PS 220V -> 110V that I normally use for equipment that needs 110V, so I bought locally nice adapter for 48V DC and it ran off it for months and I hope I didn’t fry it with non-approved ps

ok, the phone runs again, must have been some fluke but it really looked gone for about and hour and I am not sure what I did that brought it back from grave, I pulled network cable off and kept plugging in power (shaking, knocking and flexing it didn’t do anything) and at one point it just came on again and it was like nothing happened, both extensions registered and working, must have been some lark that it got stuck like that after a reboot, if anybody had such a thing happen and knows something about it, I’d like to hear what’s happened if it shoud happen again

anyway, I am getting it pat down now, I deleted registration from the Global Settings page (that one has now only some advanced SIP info there) and put server registration on Line1 and Line2 pages - both Proxy and Registrar Server fields with my asterisk’s FQDN and both on port 5060 - and what do you know but both lines run just fine, ports at asterisk as well as phone end are all left at 5060 and asterisk seems to take care of it on its own, in SIP Info on asterisk it is showing both of these lines as using port 1024 and about 250-300 ms lag which is acceptable in real use when talking on the lines

it looks I got finally handle on this phone and it is all due to that hint to make Proxy Server entry in the phone setup point directly to my asterisk, same as the Registrar Server entry both using port 5060, simplest things are most difficult as my case proves

now I am muling exactly how to exploit the fact that I can reigster the phone to as many extensions on asterisk as it has lines, only use that comes to me is to leave line1 to a given extension for the phone location and use line2 for connecting to a trunk for calling out (POTS termination) and maybe another line for DID incoming calls - one will be able to tell by which line is flashing what kind of call is coming in (internal or external) and each line can have distinct ringing, easier to setup than via dial plans on asterisk end I think (remainds me to delete dial plan entry in the phone, I believe it should all be left to asterisk)

Good diagnostics, yes you can register multiple lines on one phone to the remote server. Since it is one inside IP address it only requires one translation. If you had more than one physical phone then you may have problems. Some phones can handle it and some can’t.

I have only tried with Polycom’s I can send them out in the field and I get about an 80% success rate.

“If you had more than one physical phone then you may have problems. Some phones can handle it and some can’t.”

good heads up info, at least I will know what goes on when or if I should run into difficulties with multiple phones, actually I am gonna try it tomorow, I have two Aastra’s 480i here

so far before going to bed I configured six lines on one phone and they all work, also found if one deletes dial plan from the phone it refuses to call out DOH

I must say it looks impresive seeing six remote SIP lines registered and working in asterisk info, I feel like I have finally arrived after some years of playing with windows based PBXes and then finally seeing the light (asterisk) and using IAX remote extensions while figuring out for ages how to get remote SIP phone working, thx

/Edit: I have couple of Aastra 480i phones working as remote extensions from behind the same router now, I am lucky, also intercom works between remote extensions which was a dream I had but thought it wouldn’t work and it does, I can now recommend Aastra phones, only pitfall is the phone’s powersupply addapters, you need two, one for the phone (48V DC) and another for the wireless station (9V AC) and the 48V one burns out when run off 220->110V transformer in European setting, it is very sensitive to overvoltage that all other equipment is ok with), just the fact that they use odd addapter for the wireless phone (9V instead more typical 12V and AC to boot) is unnecessary potential complication and it doesn’t end there, they used the power plugs of two kinds (2.5 & 2.1 mm inside pin) - those techs responsible for that would really deserve some kicking where it hurts if you asked me, it all makes these phones way more expensive in the end for many buyers I imagine

Hi, I exactlly followed the instruction…, but I got problems as well:

  1. My trunk suddenly failed (after I edited the sip_nat.conf file and reloaded the server.

  2. My internal extensions do not have ring back tone when I call out.

I did not proceed to test the remote extension, because the internal extensions are more important to work well. Any ideas?

My sip_nat.conf contents are:

Please do not hijack a message. You will be MUCH better off by posting this as a new question that way people will see it and answer. This is also rude to the original writer as I’ll bet he/she has new message notification turned on and now is getting notifications for things they don’t care about any more.

FYI: there are THREE important lines that must be in a sip_nat.conf file and you only have 1.

not supposed to write in that last IP number triplet (not sure why it is called ‘octet’, do it as I edited it, the address externhost= ends with .com or .net typically (or is .info now valid address ending ?)
you must have setup some dynamic IP address mapping service with somebody out there

you can always edit out the lines and reload the asterisk but I doubt those entries would cause the havoc you talk about