Remote SIP .... after few minutes become...UNREACHABLE!

Hi everybody !

I had 1 asterisk box (CentOS 5.0, Asterisk 1.4.18, FreePBX 2.4.0) … work perfect !

All of SIP client in local network is no problem when register with Asterisk box.
But the problem happen with Remote SIP :

  1. The Asterisk box has been NAT (ports : 5060, 10000 - 20000, 22, 80)
  2. Softphone register from outside is OK … and work !
  3. Then I used 10 IP-Phone (Grandstrem GXP-2000) register with Asterisk box from outside, All of IP-Phone is registed and work about only 5 minutes. But after that all the status of IP-Phones has been change from … OK … to … UNRECHABLE !

As follow :

SIP in Local network :

Remote SIP register OK :

After 4-5 minutes … become UNREACHABLE :

I don’t understand why ? pls give me any ideas about this problem !

Thanks for all !

====== Contact info ==========
Name : Lam The Nhan (Steven)
E-mail : [email protected] |
Mobile phone No. : +84 918633646
Home phone No. : +84 9402331


On most systems the Sip registration period is 300 seconds or 5 minutes. So what has happened is that the phone has not re-registered. One reason might be that the remote phone is also behind a Firewall and might need port UDP 5060 opened up and forwarded. On some older firewalls this is needed. You also might want to search the forums as I think there are several posts on using the Grandstrem GXP-2000 phones. I don’t use those so don’t know of any issues but if thee are others I’m sure have posted about it.

Also check that the extension settings have nat=yes set. Another fix for some is to decrease the sip registration period. A side effect of this is that you will a slight increase in traffic as it will be sending more registration information back and forth more often.

Hi fskrotzki,

Thanks for reply. I has been google search so much but can’t find any post about this problem.
But you know that I can use Softphone X-Lite registed and work perfect ! But have probem with IP-Phone Grandstream … that mean anything about ports 5060, 10000-20000 is OK.

OK. Let me check again.

Thank so much,

====== Contact info ==========
Name : Lam The Nhan (Steven)
E-mail : [email protected] |
Mobile phone No. : +84 918633646
Home phone No. : +84 9402331

I have this problem as well but I am using different SIP gateway device connected through modem. It is registered but it shows unreachable at my freepbx server even there is no firewall inside the modem.

It is registered earlier on but it becomes unreachable suddenly.

Please help. Thank you

Most of the times those problems are firewall state tables / NAPT problems / ports conflicts / state tables conflicts.

They are not easy to solve without an advanced knowledge about NAPT (network address and port translation) and SIP / RTP.

Using a software like winstun can give interesting informations about your firewall and will give you a basis to solve your problem.

Using a SIP proxy deamon on the router, can solve the problem. Your configuration is like Centrex IP. Centrex IP is crap. The best is to put an IPBX at each site. This gives a realy more reliable setup, as you can manage redundant trunks on this IPBX.

If you want to stay Centrex and there are more than one phone, you can try to use a different SIP port for each phone, and port forward each one to the right phone. This will effectively bypass the automatic NAPT.

5060 for the first, 5062 for the second one, and so one.

5061, 5063 and so on will be RTCP ports (not supported on crap Grandstream phones).

Next, try Aastra phones, they have advanced options to solve NAT problems (UpnP support, turn and stun support).

I bought ten Grandstreams a couple years ago and they are all in the trash today. Quite expensive compared to the very bad manufacturing quality. And a fully buggy firmware, more buggy version after version… I remember as well a GXP2000 going directly in the trash after activating vlans. Firmware crash with no recovery possible…

Just configure the GXP-2000 on ACCOUNT 1:
Set NAT Traversal to: NO, but send KEEP-ALIVE , if not then change it to Yes.

Will be good idea to upgrade your firmware to the latest

I got more than 500 Grandstream phones (different models) working without issues on few customers.

I tried the No, but send keep-alive to no avail.

Works great for the first 30 minutes, but then is unreachable. My x-lite stays connected.