Remote Phones Registration Through Sangoma SBC


(Brian) #1

Hello,

I’m trying to configure my remote phones to register through my Sangoma SBC to my PBXact. I already followed all documentation and videos about the proper configuration for Remote Phones but i’m still getting error “404 Not Found” with my pjsip extensions registration. I do can register the phones on the local network no problem but not from the outside.

See example when i try to register remotely through the SBC ( No Endpoint Found ) but then next i try to register to the PBXact directly locally and its reachable:

Also i did some packet capture the remote registration through the SBC gets rejected. (New user so i cant post more than one image now).

**This is my first configuration. I’m sure i committed some config errors but not sure where. Please any advice on what to look for first.

Thanks!


(Brian) #2

Capture Image:

You can see how the SBC is forwarding the registration to the PBXact (10.10.20.2) and getting a 404 Not Found:

(66.229.=Remote Location IP) (72.28.=SBC WAN IP) (10.10.20.1=SBC LAN IP) (10.10.20.2=PBXact)


(Quarea) #3

Hello,

Do you have a trunk SIP (SBC-Trunk-1) configured with the SBC ip address and port? Try to disable it, whether then remote user registration works, you need to configure different SIP profiles in SBC, one for remote users and other for trunks.

Regards,


(Brian) #4

Hi,

I have 3 Trunks in the SBC and 4 SIP Profiles. And i have a (domain 10.10.20.2 PBXact) bind to my |External_Phone_SIP_Profile|profile so it forwards the registration to the PBXact box.

SIP PROFILES:
72.25 (SBC WAN Side) - 10.10.20.1 (SBC LAN Side)
|External_Phone_SIP_Profile|profile |sip:NetBorder@72.25.XX.XX:5060|RUNNING|| 5060
|Internal_Phone_SIP_Profile|profile |sip:NetBorder@10.10.20.1:5060|RUNNING|| 5060
|Internal_Trunking_SIP_Profile|profile |sip:NetBorder@10.10.20.1:5080|RUNNING|| 5080
|External_Trunking_SIP_Profile|profile |sip:NetBorder@72.28.XX.XX:5080|RUNNING| 5080

TRUNKS:
10.10.20.2 (PBXact Box)
|CallTower (Provider Port 5080) |205.196.XX.XX |External_Trunking_SIP_Profile||
|PBXact_Phones |10.10.20.2 |Internal_Phone_SIP_Profile||
|PBXact |10.10.20.2 |Internal_Trunking_SIP_Profile||


(Quarea) #5

Hello Brian,

Do you have port 5080 configured in the PBXact trunk configuration? If you don’t configure port in trunk configuration PBXact dosen’t know from which profile comes the request because the source IP is the same.

Profile Internal_Trunking ----------------------------------- PBXact host=10.10.20.1 port=5080
Profile Internal_Phones ------------------------------------ PBXact host=10.10.20.1 port=5060 (default)

Regards,


(Brian) #6

Yes i do have 2 Trunks setup on my PBXact box:
**PJSIP is listening on 5060
Trunk1:

Trunk2:
Same configuration but SIP Server Port = 5080


(Quarea) #7

Hi,

You have to delete Trunk1. Remote users doesn’t need a SIP trunk. They are like local extensions. It’s like whether you configure a SIP trunk fore each local extension, it has non sense.

Regards,


(Brian) #8

Interesting because i was trying to follow some notes that i got from a Sangoma representative:

> So:
>
> SBC
> 4 sip profiles (2 for remotes phones, one internal and one external, and 2 for the provider, also one internal and one external)
> 3 trunks (2 internals with the PBX, and 1 external with the service provider)
> 4 call routings (2 for remotes phones, one internal and one external, and 2 for the provider, also one internal and one external)
>
>
> PBX
> 2 trunks (internals with the SBC)
> 1 outbound route (for outbound calls to the service provider going through the SBC)

Either way i get the same result:

[2020-04-08 11:40:36] WARNING[3201] res_pjsip_registrar.c: AOR ‘3000’ not found for endpoint ‘SBC-Trunk-2’


(Quarea) #9

Hi,

Could you paste SBC Domain configuration, and SBC-Trunk-2 configuration?

Regards,


(Brian) #10

Here are my Domain and 3 Trunks config from my SBC:


(Brian) #11

Trunks here:


(Brian) #12

Trunk SIP Provider Here:


(Quarea) #13

And SBC-Trunk-2 configuration in PBXact?


(Brian) #14

Here Trunk-2


(Quarea) #15

Have you tried to disable this trunk too? Just for demonstrate whether this trunk is catching remote user registers


(Brian) #16

OK,

So when i disabled both Trunks on my PBXact the remote extension goes Online but at soon as i Enable any of the Trunks i get the 404 Not Found. What you think can be the problem here?


(Brian) #17

OK,

So when i disabled both Trunks on my PBXact the remote extension goes Online but at soon as i Enable any of the Trunks i get the 404 Not Found. What you think can be the problem here?


(Quarea) #18

This is because, I don’t know why, your trunks are catching the Register but the user doesn’t match, obviously.
Could you paste the REGISTER packet received in PBXact?


(Brian) #19

Issue was resolved by a Sangoma Support. They SSH to my PBXact and issue was corrected.

Thanks!


(Quarea) #20

Hi Brian,

Perfect! Do you know what was the issue? What did they correct?