Remote Phone 20 Second Disconnect

I have searched the forums and found several similar issues but none of the solutions have solved my problem.

The Problem:

Remote phones: all of them (Cisco, Astra, Soft Phones) disconnect after exactly 20 seconds. Phones register properly, make and receive calls but for just 20 seconds.

My Setup:

Internal Network: 192.168.1.X
Public: 75.x.x.x
Router: I’ve tried both DD-WRT (which have always worked for my PBXs) and a Netgear Router.
PBX is plugged in directly to the Router

What I’ve Checked:

(1) NAT. This seems to be the normal issue but after checking all of the suggestions I’ve found, my settings were already correct.
(2) Public IP and local network correct in the PBX= Yes
(3) SIP.Conf does show the correct public IP, NAT on
(4) Extension settings: I’ve checked the port settings on the extension and it is correct
(5) network hardware. A tech suggested it could be a hardware issue so I replaced the only network equipment between the PBX and ISP – the router.

Additional Note:

the only thing I can find out of the ordinary is the company that sold this modified the SIP port to 5070. The phone does register on 5070 but will not on 5060, as expected. But I guess there could be something messed up there.


I certainly would appreciate any suggestions. I’ve tried everything I can think of but have not found a solution.