Remote Factory Reset Options? - Sangoma Phones


#1

FreePBX 15, EPM current. Short of opening up a feature request, which I will probably do anyway, I’m looking for a way to remote factory reset Sangoma phones. I know I can auto provision and do, from EPM, but I am looking for a way to factory reset remote users phones without the user having to be present or intervene.

We have instances of phones that will lose provisioning and after all troubleshooting, sometimes a factory reset and reprovision is the only cure.

Only option I have currently is to remote desktop into their PC, then get in the phone GUI from their desktop. But if anyone knows a better way…Thanks in advance.


#2

You can press *** then hold x for 10 seconds. Or “tap tap tap boom” as we call it.


(Lorne Gaetz) #3

https://wiki.freepbx.org/pages/viewpage.action?pageId=56230226


#4

Thanks for the link but I’m attempting to find a way to do this without the end user being present or having to go “hands on”, even though the “tap tap tap boom” is dirt simple. Boils down to remote users not being at their phones until shift start.


#5

Thanks! Overlooked that one…I like the name, I may steal it :slight_smile: Bad enough its used enough to have a nickname…


(Dave Burgess) #6

Factory resetting the phone seems like a shotgun approach to killing a mosquito.

Perhaps you could tell us what your actually trying to do and one or more of us could offer less “drastic” solutions.


#7

Thanks for the reply. As I stated above “We have instances of phones that will lose provisioning and after all troubleshooting, sometimes a factory reset and reprovision is the only cure.” is what Im trying to alleviate.

It’s not daily, nor with every phone, but it happens often enough to look into alternatives. I do reboot remotely, as well as have the phone auto provision via EPM button, but this is the only real fix I have found. There are also plenty of times where you can change a template for a phone and even rebooting and auto provision will not force the phone to pick up the change, forcing me to factory reset to get the changes to apply.