Remote extensions no audio

I had freepbx running great for while, but hard drive failure forced me to reinstall on a new machine.

I used the same settings as before on the new machine but I now have no audio on remote extensions and outgoing calls disconnect with not found message when I call outside numbers from remote extension.

I am running freepbx distro, fresh install this morning.
Once installed I registered the machine
-updated all modules
-configured trunks for two lines
-configured inbound and outbound routes for each line
-changed port from 5060 to 6060 in settings
-configured extensions
-configured router for rtp10k-20k to machine
-forward port 6060 to machine

Testing between two extensions within network is perfect
calls inbound and outbound are perfect
only trouble is remote extension sends no audio but can hear caller on extension inside network.
Calls to outside numbers disconnects right away with not found message on device.

I copied the asterisk logfile up to this point just incase.

Also I have multiple servers on a single public static IP. I have not found any info on this being a problem, yet. I do have the machine on a static internal IP with all internet traffic going to webserver and pbx traffic going to pbx server.

Seems to be the most common problem on here (no audio / one-way audio)

If the phone is registering, then your 6060 port should be OK.

If your phones are presenting as external IP addresses instead of the gateway (most likely) you may need to look at your allowed IPs on your phone system. For example, if you have “Deny Allow” and your phones connecting have an external IP, they wouldn’t be within that range.

If they are connecting with VPN, they should have an “inside” address.

If you are running a firewall on your PBX, you may want to try disabling that (temporarily) to see if that resolves your issue (process of elimination)

Usually in IP phones, a one-way talk path or no talk path is because it can’t set up the call for some reason; rtp / udp isn’t getting through.

Oh… you may also look in your phone’s settings and see if there is “Enable NAT” or some similar setting; since you are NATting through the system; especially if the remote phones don’t have a public IP address (i.e. they are behind a home router or other such thing, so the phone may have a non-routable address… in other words…

Phone ( --> ( GW) Home Router ( WAN) --> (Internet) --> ( WAN) Corp Router ( GW) --> (PBX)

If NAT isn’t enabled on the phone, it may have a real hard time especially if the phone and the PBX are on the same subnet, but “split” over a WAN connection…

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.