Remote extension issues


(AC-Jay) #1

Hello -

I’m having two issues with a remote extension that I have set up at my home (PBX is located in my office). I’m hoping someone can help.

Issue 1 - I have no audio in either direction. The phone registers properly and I can both call it and make outgoing calls. A search of the forums seems to indicate that I could possibly either forward additional ports for audio or set some NAT-related flag on the extension. The relevant posts are very old and I am unable to find either option in my newer version of FreePBX.

Issue 2 - I cannot get the PBX to play a ringing tone during calls to the remote extension unless I use a queue. I have an inbound route (DID on a T1) that I’d like to have the destination be my remote extension and have it ring until answered or voicemail kicks in. Having the destination be my extension plays dead air until either the phone is answered or it fails over to voicemail. Having the destination be a queue which my extension is an agent of plays the ringing tone properly. It seems like I should be able to have it ring the extension directly without the need for a queue, but I am also unable to figure out how to get this to work as well.

Any help would be much appreciated.

Thanks in advance,
J


(Matt Brooks) #2

About 90% of the time, issues with audio have to do with the network. Take a look at this article that is found on the wiki and try each suggestion out: https://wiki.freepbx.org/pages/viewpage.action?pageId=24051965

If you’re still having issues, we can do a deeper dive, but I’m going to still default to something isn’t right on the network side of things.


(AC-Jay) #3

Hi Matt -

Thanks for the reply.

Does it matter that my remote extension (and all others) is a pjsip extension and not a chan_sip extension?

I definitely don’t have the RTP ports open on my firewall so I will try that to see if it resolves the audio issues. Everything else on the page matches what I have in my current settings.

Any thoughts on the ringing problem?

Thanks again,
J


(Matt Brooks) #4

@acjay PJSIP is the recommended option as chan_sip will be removed from FreePBX in a future release, so you’re good there.

As far as the ringing problem, that could be network related as well. Although I’m not sure. Could also be an issue with the phone itself. If you’re able to resolve your audio issues and this is still happening, then a network capture maybe required to figure out what exactly is happening there.


(AC-Jay) #5

@mbrooks I’ve opened the RTP ports on my firewall and will be able to test tonight when I get home.

The ringing problem is weird as it rings when the inbound route has a queue as its destination but not when I have an extension.

This rings:
image

This plays dead air:
image

Would an audio issue (i.e. RTP ports not being forwarded) cause no ring sounds to be played on an extension vs a queue?

I guess maybe I’ll find out tonight, but I would have expected it to not work on the queue destination as well.

Thanks again for all the help.


(Lorne Gaetz) #6

You can definitely get different audio behavior on queues vs. extensions because calls going to a queue get answered by the PBX and audio sent on the channel before the call goes to the ext. More info in this blurb: SIP Port Forwarding


(AC-Jay) #7

@mbrooks

Ok, so opening up the RTP ports on my firewall restored two way audio, however it introduced another problem: I am unable to call the extension.

I can make outbound calls from it but cannot call it. It immediately goes to the unavailable message.

For reference, I have ports 10001-15000 forwarded to my PBX and I’ve updated the settings within FreePBX to match (I have port conflicts beyond 15000).

I have restarted both my phone and Asterisk to no avail. The phone shows as registered and, again, I can make outbound calls, but cannot call it.

I’ve watched the console while placing the call and I don’t see anything that indicates something wrong.

Any commands I can run from the console that would produce output you folks could look at that might help?

Thanks much,
J


(Matt Brooks) #8

@acjay when you say you can no longer call it, does that mean that you can’t call it from another extension on the PBX or you can’t call it through a SIP provider?

If it’s from the local extension, is that from a phone that’s on the local network, same as the phone, or it on an external network? All of these could be different issues depending on the setup. If on the same network, it does make me wonder with what IP address the phone is trying to connect to, the internal or external IP address. If it’s trying to connect to the external IP address, it’s possible that the router isn’t smart enough to route the traffic accordingly, so you may have to make sure the phone see the PBX with the local IP address.

If it’s through a SIP provider, I’m not sure. It could be many reasons. Their support maybe able to help you with configuration on that side of the call and possibly provide you with traces.


(AC-Jay) #9

@mbrooks I cannot call it from another extension nor can I use an inbound route with the extension as its destination – both go immediately to voicemail.

It shows as registered both on the phone’s UI and in Asterisk and I can make outbound calls.

It is the sole external device connected to my PBX, so nothing is on the same network. All other devices are behind my firewall at the office. I suspect you’re correct in that it’s a routing issue, but I’m not sure how to fix it.


(AC-Jay) #10

Ok, so a pjsip show contacts shows that my remote extension is being referenced by its local (on its end) IP and not the public IP it should be using.

I thought I had all NAT settings enabled but perhaps I need to specifically say this extension is remote (and NAT’d)? How can I let FreePBX know this is a remote extension?

Thanks,
J


(Lorne Gaetz) #11

Edit PJSIP extension, advanced tab, enable rewrite contact.


(AC-Jay) #12

@lgaetz Was already enabled.


(AC-Jay) #13

@mbrooks @lgaetz

Any thoughts?

Thanks,
J


(AC-Jay) #14

@mbrooks @lgaetz

Still unable to call this extension. Any ideas?

Thanks,
J


(AC-Jay) #15

Update -

After changing the Transport setting:

from Auto to 0.0.0.0-udp and rebooting the phone, I am now seeing the correct IP address (my remote extension’s public) in the CLI and I can call the phone.

I am still, however, unable to make the phone play ring tones while dialing if I set the destination of my inbound route as an extension. If I set it as a queue that includes my remote extension, it rings properly. If I call the extension directly, it rings properly. Only when I have the extension as a target of an incoming DID does it play dead air.

Thoughts?

Thanks,
J


(system) closed #16

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.